Package Details: wingpanel-git 2.3.2.r31.g92e71f7-1

Git Clone URL: https://aur.archlinux.org/wingpanel-git.git (read-only, click to copy)
Package Base: wingpanel-git
Description: Stylish top panel that holds indicators and spawns an application launcher
Upstream URL: https://github.com/elementary/wingpanel
Licenses: GPL3
Groups: pantheon-unstable
Conflicts: wingpanel
Provides: libwingpanel.so, wingpanel
Submitter: alucryd
Maintainer: SolarAquarion
Last Packager: SolarAquarion
Votes: 43
Popularity: 0.002510
First Submitted: 2017-04-30 15:25
Last Updated: 2021-02-21 04:49

Required by (30)

Sources (1)

Latest Comments

« First ‹ Previous 1 2 3 4 5 6 7 Next › Last »

Ner0 commented on 2012-12-06 15:35

Right, forgot about that

alucryd commented on 2012-12-06 15:25

@Ner0: You need to add -DVALA_EXECUTABLE="$(type -p valac-0.16)" to the cmake options otherwise it uses 0.18.

alucryd commented on 2012-12-06 15:08

Thx for the answers both of you, I will test it now. BTW, you forgot a quote at the end of line 7 in your install file Ner0.

alucryd commented on 2012-12-06 15:04

Thx for the answers both of you, I will test it now.

n00b commented on 2012-12-05 22:28

for me with this pkgbuild http://pastebin.com/dcbtrFkm, il build e run fine even with the indicators

n00b commented on 2012-12-04 12:10

i tried to compile with vala 0.16.1 it compile and run fine, even with the indicator, so i think that vala-016 should be added as compile dependency

Ner0 commented on 2012-11-26 15:34

I think this is due GTK 3.6. Elementary OS still uses GTK 3.4 and vala 0.16 so there are conflicts.

alucryd commented on 2012-11-26 15:24

wingpanel is unable to load any indicator for me. It launches fine, along with slingshot, but as soon as I install indicator-session or indicator-sound, it crashes at launch, saying it can't load lib***.so. Can somebody reproduce this?

Ner0 commented on 2012-03-15 19:52

Ok, i've added libindicator3 and hicolor-icon-theme deps.
I'm getting the same warnings as you, but have no problems with slingshot.
Are your dependencies stable (glib2, gtk3, vala)?
Also, try installing the latest libindicator3: http://aur.pastebin.com/0Gk7khS5

Anonymous comment on 2012-03-15 17:47

Okay, I managed to get round this by installing libindicator3 from the AUR

However, now I'm getting some issues with GTK. Please see the below screenshots and terminal output:

This is for wingpanel (you can see just below it that there are some GTK issues: http://oi42.tinypic.com/9k321f.jpg

And here's what happens when I click 'Applications' to launch slingshot: http://oi41.tinypic.com/6h59he.jpg

Here's the terminal output: http://pastebin.com/n1NePbGS