Package Details: wingpanel-git 2.3.2.r5.ge864189-1

Git Clone URL: https://aur.archlinux.org/wingpanel-git.git (read-only, click to copy)
Package Base: wingpanel-git
Description: Stylish top panel that holds indicators and spawns an application launcher
Upstream URL: https://github.com/elementary/wingpanel
Licenses: GPL3
Groups: pantheon-unstable
Conflicts: wingpanel
Provides: libwingpanel-3.0.so, wingpanel
Submitter: alucryd
Maintainer: SolarAquarion
Last Packager: SolarAquarion
Votes: 41
Popularity: 0.000013
First Submitted: 2017-04-30 15:25
Last Updated: 2020-08-10 17:37

Required by (20)

Sources (1)

Latest Comments

1 2 3 4 5 6 ... Next › Last »

AlexWayfer commented on 2020-03-24 22:55

[17/37] Compiling C object 'wingpanel-interface/fb1d034@@wingpanel-interface@sha/meson-generated_FocusManager.c.o'.
FAILED: wingpanel-interface/fb1d034@@wingpanel-interface@sha/meson-generated_FocusManager.c.o 
cc -Iwingpanel-interface/fb1d034@@wingpanel-interface@sha -Iwingpanel-interface -I../wingpanel/wingpanel-interface -I/usr/include/gala -I/usr/include/glib-2.0 -I/usr/lib/glib-2.0/include -I/usr/lib/libffi-3.2.1/include -I/usr/include/mutter-5 -I/usr/include/cairo -I/usr/include/pixman-1 -I/usr/include/freetype2 -I/usr/include/libpng16 -I/usr/include/harfbuzz -I/usr/include/gio-unix-2.0 -I/usr/include/libmount -I/usr/include/blkid -I/usr/include/gsettings-desktop-schemas -I/usr/include/gtk-3.0 -I/usr/include/pango-1.0 -I/usr/include/fribidi -I/usr/include/gdk-pixbuf-2.0 -I/usr/include/atk-1.0 -I/usr/include/at-spi2-atk/2.0 -I/usr/include/dbus-1.0 -I/usr/lib/dbus-1.0/include -I/usr/include/at-spi-2.0 -I/usr/include/mutter-5/clutter -I/usr/include/json-glib-1.0 -I/usr/include/mutter-5/cogl -I/usr/include/granite -I/usr/include/gee-0.8 -flto -fdiagnostics-color=always -pipe -D_FILE_OFFSET_BITS=64 -w '-DGETTEXT_PACKAGE="wingpanel"' '-DG_LOG_DOMAIN="wingpanel"' -march=x86-64 -mtune=generic -O2 -fno-plt -D_FORTIFY_SOURCE=2 -fPIC -pthread -DCLUTTER_ENABLE_COMPOSITOR_API -DCLUTTER_ENABLE_EXPERIMENTAL_API -DCOGL_ENABLE_EXPERIMENTAL_API -DCOGL_ENABLE_EXPERIMENTAL_2_0_API -MD -MQ 'wingpanel-interface/fb1d034@@wingpanel-interface@sha/meson-generated_FocusManager.c.o' -MF 'wingpanel-interface/fb1d034@@wingpanel-interface@sha/meson-generated_FocusManager.c.o.d' -o 'wingpanel-interface/fb1d034@@wingpanel-interface@sha/meson-generated_FocusManager.c.o' -c 'wingpanel-interface/fb1d034@@wingpanel-interface@sha/FocusManager.c'
In file included from wingpanel-interface/fb1d034@@wingpanel-interface@sha/FocusManager.c:27:
/usr/include/mutter-5/meta/meta-workspace-manager.h:73:56: error: unknown type name ‘MetaDisplayCorner’; did you mean ‘MetaDisplay’?
   73 |                                                        MetaDisplayCorner     starting_corner,
      |                                                        ^~~~~~~~~~~~~~~~~
      |                                                        MetaDisplay
[19/37] Compiling Vala source ../wingpanel/src/PanelWindow.vala ../wingpanel/src/S...idgets/Panel.vala ../wingpanel/src/Widgets/StyleClass.vala lib/wingpanel-2.0.vapi.
../wingpanel/src/Services/IndicatorSorter.vala:79.13-79.60: warning: Gee.Map.contains is deprecated. Use Map.has_key
../wingpanel/src/PanelWindow.vala:45.26-45.51: warning: Gdk.Screen.get_primary_monitor has been deprecated since 3.22
../wingpanel/src/PanelWindow.vala:107.26-107.51: warning: Gdk.Screen.get_primary_monitor has been deprecated since 3.22
Compilation succeeded - 3 warning(s)
[22/37] Linking target lib/libwingpanel-2.0.so.0.2.0.
ninja: build stopped: subcommand failed.
==> ERROR: A failure occurred in build().
    Aborting...
Error making: wingpanel-git

alucryd commented on 2020-03-16 09:11

Forgot to disown this, please do whatever you see fit with it.

quequotion commented on 2020-03-15 18:14

You could lower the gala and granite dependencies to their [community] versions to make it easier for people to build this (in a clean chroot).

alucryd commented on 2019-11-04 14:25

Good news, confirmed it builds fine now.

marlock commented on 2019-11-01 15:14

Hi guys. Pull request with support for mutter 3.3x was just merged into upstream. https://github.com/elementary/wingpanel/pull/260

alucryd commented on 2019-09-09 12:42

Sure, you can build an old mutter, make it so that it doesn't conflict with the current one, and build against it. But I don't have time to waste on this, bugging upstream so they work on an update like they did with gala would be much more productive.

Nietzsche commented on 2019-09-09 12:34

Yes, I read the pinned comment. And since I read it, I was able to formulate my question to ask if there also is a way installing it explicitly not using the latest libmutter version.

alucryd commented on 2019-09-09 12:18

So much for pinned comments... Do you guys even read them?

Prosto_user commented on 2019-09-08 11:35

I join the Nietzsche comment.

Nietzsche commented on 2019-09-06 13:54

@alucryd: Sorry for bothering all the time. Is there a way to install Pantheon on Arch at the moment? Or do I have to wait until they add support for the new mutter version? Just wondering if I somehow could go with an older mutter version