Package Details: wine-ivb 2.6-1

Git Clone URL: https://aur.archlinux.org/wine-ivb.git (read-only)
Package Base: wine-ivb
Description: A compatibility layer for running Windows programs: indexed vertex blending - https://bugs.winehq.org/show_bug.cgi?id=39057
Upstream URL: http://www.winehq.com
Keywords: wine
Licenses: LGPL
Conflicts: bin32-wine, wine, wine-wow64
Provides: bin32-wine=2.6, wine=2.6, wine-wow64=2.6
Replaces: bin32-wine, wine
Submitter: grazzolini
Maintainer: grazzolini
Last Packager: grazzolini
Votes: 5
Popularity: 0.003196
First Submitted: 2016-01-15 18:24
Last Updated: 2017-05-23 12:25

Dependencies (137)

Required by (144)

Sources (6)

Latest Comments

slyscorpion commented on 2017-02-03 20:41

Hi again,

The patch has been updated for Wine 2.1: https://bugs.winehq.org/show_bug.cgi?id=39057#c80

grazzolini commented on 2017-01-29 11:42

@slyscorpion

Thanks for the warning. I'm a little bandwidth restricted right now, but I'll probably update it later today or tomorrow.

Cheers

slyscorpion commented on 2017-01-29 04:08

Hi,

The creator of the indexed vertex blending patch has updated the patch a day or so ago: https://bugs.winehq.org/show_bug.cgi?id=39057#c79

rugaliz commented on 2017-01-16 10:30

hey, so i get this error when building...
"error: target not found: libcl
error: target not found: lib32-libcl"

muttleyxd commented on 2016-10-26 16:13

@grazzolini
If you mean DirtyCow, then that was fixed in 4.7.9. However I did update to 4.8.4 and built your 1.9.20 package. It works like a charm now. Finally I can play DSJ4, thanks :)

About package flagging - I'm new to AUR so I didn't even realize that one could do it, but I will use it in the future.

grazzolini commented on 2016-10-25 15:33

@muttleyxd

Please, make sure you're always with your system up to date. Kernel 4.7.10 is old, and also has a major security issue. Also, don't forget to always build in a clean dir. Pass argument -C to makepkg. Perhaps even use the devtools to build in a clean chroot.

Also, flag the package out-of-date next time. I wasn't aware the patch came out. I'm in the process of updating the package right now.

muttleyxd commented on 2016-10-25 13:27

I'm having problems with building that package. I tried removing wine and winetricks before building, but I didn't manage to do anything.

GCC 6.2.1 20160830
Linux Kernel 4.7.10

../../../wine-ivb/dlls/winspool.drv/info.c:779:13: error: ‘cupsGetPPD’ undeclared here (not in a function)
DO_FUNC(cupsGetPPD); \

../../../wine-ivb/dlls/winspool.drv/info.c: In function ‘cupsGetPPD3_wrapper’:
../../../wine-ivb/dlls/winspool.drv/info.c:807:11: error: called object ‘pcupsGetPPD’ is not a function or function pointer
ppd = pcupsGetPPD( name );


Also when I launch building for the second time, I get this:
==> Starting prepare()...
patching file dlls/d3d9/tests/visual.c
Hunk #1 succeeded at 19857 (offset 255 lines).
Hunk #2 FAILED at 22045.
1 out of 2 hunks FAILED -- saving rejects to file dlls/d3d9/tests/visual.c.rej


Also you may try uploading a new version - 1.9.20 patch is out.

Thanks in advance

grazzolini commented on 2016-07-01 17:23

@slyscorpion

I'm not the developer of the patches. I merely take the patches, apply and test them and create a package out of it. Having said that, I had some contact with the developer who does the patches. Unfortunately, the last version he adapted the patches for is 1.9.11.

slyscorpion commented on 2016-06-30 21:17

Are you going to update the base Wine to 1.9.13 for this?

https://www.winehq.org/announce/1.9.13