Package Details: wine-git 4.20.r74.ga9c4b309f6-1

Git Clone URL: https://aur.archlinux.org/wine-git.git (read-only, click to copy)
Package Base: wine-git
Description: A compatibility layer for running Windows programs (git version)
Upstream URL: https://www.winehq.org/
Keywords: windows wine
Licenses: LGPL
Conflicts: bin32-wine, wine, wine-wow64
Provides: bin32-wine=4.20.r74.ga9c4b309f6, wine=4.20.r74.ga9c4b309f6, wine-wow64=4.20.r74.ga9c4b309f6
Replaces: bin32-wine
Submitter: None
Maintainer: dbermond
Last Packager: dbermond
Votes: 84
Popularity: 0.003112
First Submitted: 2007-07-18 16:01
Last Updated: 2019-11-20 21:49

Dependencies (162)

Required by (244)

Sources (3)

Latest Comments

« First ‹ Previous 1 2 3 4 5 6 7 8 ... Next › Last »

greyltc commented on 2017-02-12 12:35

The build is failing with
macro.lex.yy.c:(.text+0xf4d): undefined reference to `yywrap'
as follows

make[1]: Entering directory 'wine-git/src/wine-git-64-build/programs/winetest'
build="BUILD_INFO STRINGRES build.nfo STRINGTABLE { 1 \"`GIT_DIR=../../../wine-git/.git git rev-parse HEAD 2>/dev/null`\" }" && (echo $build | cmp -s - build.rc) || echo $build >build.rc || (rm -f build.rc && exit 1)
make[1]: Leaving directory 'wine-git/src/wine-git-64-build/programs/winetest'
make[1]: Entering directory 'wine-git/src/wine-git-64-build/programs/winhlp32'
../../tools/winegcc/winegcc -o winhlp32.exe.so -B../../tools/winebuild -m64 -fasynchronous-unwind-tables \
-mwindows callback.o hlpfile.o macro.o string.o winhelp.o macro.lex.yy.o winhlp32.res -lshell32 \
-lcomctl32 -lcomdlg32 -luser32 -lgdi32 ../../libs/port/libwine_port.a -Wb,-dshell32 -Wb,-dcomctl32 \
-Wb,-dcomdlg32 -Wl,-O1,--sort-common,--as-needed,-z,relro
macro.lex.yy.o: In function `yylex':
macro.lex.yy.c:(.text+0xf4d): undefined reference to `yywrap'
collect2: error: ld returned 1 exit status
winegcc: gcc failed
make[1]: *** [Makefile:353: winhlp32.exe.so] Error 2
make[1]: Leaving directory 'wine-git/src/wine-git-64-build/programs/winhlp32'
make: *** [Makefile:20951: programs/winhlp32] Error 2

Is this upstream's problem or ours?

z3ntu commented on 2017-01-11 13:09

flex 2.6.3-1 seems to break the compilation. Downgrading to 2.6.1-1 (https://archive.archlinux.org/packages/f/flex/flex-2.6.1-1-x86_64.pkg.tar.xz) fixes it.

sidneycrestani commented on 2016-12-07 00:04

the --with-gstreamer option is already there, that comment is from the community repo

your issue #2 was fixed on my second commit

C0rn3j commented on 2016-12-06 17:11

Thanks! That seems to have fixed it!

I just have 2 issues left with this package
1)# Gstreamer was disabled for FS#33655
https://bugs.archlinux.org/task/33655

As you can see this issue was fixed upstream.

https://bugs.winehq.org/show_bug.cgi?id=30557

2) My comment from 2016-11-20 13:36 on this page describes the issue

sidneycrestani commented on 2016-12-06 00:22

I copied the PKGBUILD dependencies from upstream, my bad

EDIT: Should be fixed now

C0rn3j commented on 2016-12-05 22:28

Thanks for taking over the package and fixing the issues, but now there's a problem with
- mesa-libgl (package found) [makedepend]
- lib32-mesa-libgl (package found) [makedepend]
:: mesa-libgl and nvidia-libgl are in conflict (libgl). Remove nvidia-libgl? [y/N]

Tl;dr people with binary Nvidia drivers are being forced to use mesa

C0rn3j commented on 2016-12-04 00:46

The lines that's twice in the PKGBUILD:
libcl lib32-libcl
need to be replaced by:
opencl-icd-loader lib32-opencl-icd-loader

Because of recent changes.

C0rn3j commented on 2016-11-20 13:36

Installing this package removes `wine` package, which requires removing packages like `winetricks-git`/`winetricks`/`wine-mono`/`wine_gecko` as they rely on `wine`, so it'd be great if the PKGBUILD was edited to provide `wine` or whatever change needs to be done to not break other packages.

sxe commented on 2016-05-14 09:38

Hey guys, i merged the latest wine PKGBUILD changes, builds fine for me now.

@Xylemon I would like to keep in sync with the original wine PKGBUILD as close as possible.

Greetings

Xylemon commented on 2016-04-08 18:11

Could you add OSS to the optional deps as well?