Package Details: wesnoth-devel 1.15.17-1

Git Clone URL: https://aur.archlinux.org/wesnoth-devel.git (read-only, click to copy)
Package Base: wesnoth-devel
Description: development version of a turn-based strategy game on a fantasy world
Upstream URL: https://www.wesnoth.org/
Keywords: game strategy
Licenses: GPL
Submitter: valdar
Maintainer: valdar
Last Packager: valdar
Votes: 59
Popularity: 0.000000
First Submitted: 2007-02-28 22:40
Last Updated: 2021-09-03 21:50

Dependencies (19)

Required by (0)

Sources (8)

Anonymous comment on 2011-08-10 12:32

can u show me your PKGBUILd pls

macxcool commented on 2011-08-09 13:11

I used the patch as-is and everything worked. Thanks Calamulus.

Anonymous comment on 2011-08-09 03:36

Ah yes, I should have confirmed that I also compiled 1.9.8 with that patch. I just changed 1.8.6 occurrences to 1.9.8 so paths get properly matched and it works.

Anonymous comment on 2011-08-08 13:34

I can confirm that the patch (https://bugzilla.redhat.com/attachment.cgi?id=514578) helped me compile 1.9.8. Without the patch the compilation fails (see macxcool's comment).

macxcool commented on 2011-08-08 13:13

That patch seems to be against version 1.8.6. Does it apply here?

Anonymous comment on 2011-08-04 23:04

Alright, it is a bug originated from a Boost rebase due to a GCC change. Details:
http://gna.org/bugs/?18399 (Wesnoth bug report)
https://bugzilla.redhat.com/show_bug.cgi?id=724818 (Redhat bug report and patch)
https://svn.boost.org/trac/boost/ticket/5279 (Boost change).

There is a patch that we might use while this gets sorted (if it even does), posted on redhat: https://bugzilla.redhat.com/attachment.cgi?id=514578

Cheers.

Anonymous comment on 2011-08-04 22:20

I'm also getting the same error, on x86_64. Skimming through the error I think it might be something from the Boost library and the noncopyable class. I'll ask on the wesnoth forums.

macxcool commented on 2011-08-04 13:19

I'm getting scons errors when building:
http://pastebin.com/v2mBRSAH

macxcool commented on 2011-08-04 12:48

I'm getting scons errors when building:
http://pastebin.com/v2mBRSAH

valdar commented on 2011-08-03 21:40

Upgraded to version 1.9.8