Package Details: weka 3.8.4-2

Git Clone URL: https://aur.archlinux.org/weka.git (read-only, click to copy)
Package Base: weka
Description: A collection of machine learning algorithms for data mining tasks
Upstream URL: http://www.cs.waikato.ac.nz/ml/weka/
Keywords: learning machine weka
Licenses: GPL
Submitter: None
Maintainer: jonathon
Last Packager: jonathon
Votes: 89
Popularity: 0.000221
First Submitted: 2006-09-14 21:36
Last Updated: 2020-01-24 17:30

Dependencies (2)

Required by (0)

Sources (4)

Pinned Comments

jonathon commented on 2020-06-03 10:58

Please be aware that "odd-numbered" releases are development releases. Please do not flag this package "out of date" because there is a new development release.

"Weka 3.8 is the latest stable version and Weka 3.9 is the development version." [1]

Latest Comments

« First ‹ Previous 1 2 3 4 Next › Last »

Anonymous comment on 2014-10-21 11:20

Please update PKGBUILD with the following:

pkgver=3.7.11

_dlver=$(echo $pkgver | sed 's/\./-/g')
_dlver_major=$(echo $_dlver | cut -d '-' -f -2)

source=(http://downloads.sourceforge.net/sourceforge/weka/$pkgname-${_dlver_ major}/$pkgver/$pkgname-$_dlver.zip
...)

md5sums=('405a0e2d5159fac36a9942b16234f8c4'
...)

Thanks.

pmvalente commented on 2014-08-24 21:51

Please update to 3.7.11.
Tks

randompie commented on 2014-01-30 18:14

Apply the patch below for 3.7.10:

--- PKGBUILD 2013-05-08 16:40:44.000000000 -0400
+++ PKGBUILD.new 2014-01-30 13:05:46.992090568 -0500
@@ -2,8 +2,8 @@
# Contributor: Dan McGee <dan@archlinux.org>

pkgname=weka
-pkgver=3.7.9
-_dlver=${pkgver//./-}
+pkgver=3.7.10
+_dlver=`echo ${pkgver} | sed 's/\./-/g'`
pkgrel=1
pkgdesc="A collection of machine learning algorithms for data mining tasks"
url="http://www.cs.waikato.ac.nz/ml/weka/"
@@ -37,6 +37,6 @@
install -m755 $srcdir/weka.sh $pkgdir/usr/bin/weka
}

-md5sums=('cb5d194337ab3a0b08edfb8a3875664c'
+md5sums=('8376eb1938f89b46f4b00bd6afc4fd4c'
'6e52180eb400fc05287c3faa927fff48'
'83a4d47ba64df90a92a38b23a14c6480')

mmm commented on 2013-11-10 19:57

@botika I would update, but the download is not working. If it's not temporary, please contact upstream to fix that.

botika commented on 2013-10-16 00:05

It's wonderfull, but actualize 3.7.10 please.

Skatox commented on 2013-07-23 01:32

I'm using 3.6.9

mmm commented on 2013-05-08 20:45

well..adopted and updated.
Some changes:
* removed gnome-gui patch, please test running from gnome, should be ok now.
* increased java heap size to 1GB from usless (256mb)
* are u guys aware we're running a devel (3.7) version here? 3.6 is the stable with bugfixes only. Is it ok? (ok for me) Opinions?

Thanks!

Anonymous comment on 2013-03-27 01:43

Hey ya'll, if anyone needs it I'm posting an updated PKGBUILD file for installing version 3.7.9. It's a really simple change, but for those unaware here is what you need:

https://docs.google.com/file/d/0B7eQIPsJcfo9ZEVvQW5GY20xd0U/edit?usp=sharing

Anonymous comment on 2011-12-06 15:00

How not aware of makepkg are you that you can't simply change two 3.7.4 references to 3.7.5 to get the new version? It is now updated, but seriously...

Anonymous comment on 2011-11-24 12:18

Any chance of updating it to >3.7.5? I have to resort to windows now to get the Time Series package to work :-(
Thanks!