Package Details: weechat-git 2.6.11.gd26893a70-2

Git Clone URL: https://aur.archlinux.org/weechat-git.git (read-only, click to copy)
Package Base: weechat-git
Description: Fast, light and extensible IRC client (curses UI). Development version.
Upstream URL: http://www.weechat.org/
Licenses: GPL
Conflicts: weechat
Provides: weechat=2.6.11.gd26893a70
Submitter: dacoit
Maintainer: AlfredoRamos
Last Packager: AlfredoRamos
Votes: 12
Popularity: 0.000028
First Submitted: 2015-08-12 21:21
Last Updated: 2019-09-18 06:42

Dependencies (23)

Required by (15)

Sources (1)

Latest Comments

Mr.Elendig commented on 2019-10-30 10:38

Regarding the JS plugin:

@FlashCode for now I don't recommend to write javascript scripts, the plugin is compatible only with old v8 lib
@FlashCode on many distros, the javascript plugin is not dsitributed any more
@FlashCode I'm not sure if this javascript plugin will stay or be removed in future

AlfredoRamos commented on 2019-09-18 06:42

@Alad well, in fact it failed because of a recent upstream changes in commit bff40e4. At the time the PKGBUILD was updated, it was working just fine.

I disabled the JavaScript plugins but commented the dependencies. The v8 package (currently only available in the AUR) downloads over 580 MiB which it my opinion, is not worth the time it adds to the build process.

I also disabled PHP plugins because I couldn't make it work even after patching the FindPHP.cmake file. I'll look into it to make it work.

I accept suggestions or patches.

Alad commented on 2019-09-17 17:15

Doesn't build after the update:

==> Starting build()...
-- Could NOT find V8 (missing: V8_LIBRARY V8_INCLUDE_DIR)
CMake Error at src/plugins/CMakeLists.txt:152 (message):
  V8 (javascript) not found


-- checking for one of the modules 'php7'
CMake Warning at cmake/FindPHP.cmake:57 (message):
  Could not find libphp7.  Ensure PHP >=7.0.0 development libraries are
  installed and compiled with `--enable-embed`.  Ensure `php-config` is in
  `PATH`.  You may set `-DCMAKE_LIBRARY_PATH=...` to the directory containing
  libphp7.
Call Stack (most recent call first):
  src/plugins/CMakeLists.txt:157 (find_package)


CMake Error at src/plugins/CMakeLists.txt:161 (message):
  Php not found


-- Configuring incomplete, errors occurred!
See also "/home/user/.cache/aurutils/sync/weechat-git/src/build/CMakeFiles/CMakeOutput.log".
See also "/home/user/.cache/aurutils/sync/weechat-git/src/build/CMakeFiles/CMakeError.log".
==> ERROR: A failure occurred in build().
    Aborting...

Mr.Elendig commented on 2019-08-08 09:24

Due to changes to the cmake setup, this will now build against python 3.

punkrockguy318 commented on 2019-02-02 19:34

The cmake line needs to include the source directory "."

cmake -DCMAKE_INSTALL_PREFIX=/usr \ -DCMAKE_BUILD_TYPE=Release \ -DENABLE_MAN=ON \ -DPYTHON_EXECUTABLE=/usr/bin/python2 \ -DPYTHON_LIBRARY=/usr/lib/libpython2.7.so \ .

punkrockguy318 commented on 2019-01-30 16:26

Recent builds are failing at the cmake step (didn't get a chance to look into it)


==> Starting pkgver()... ==> Updated version: weechat-git 2.3.105.gb38b2abe3-1 ==> Starting build()... CMake Error: No source or binary directory provided ==> ERROR: A failure occurred in build().


dacoit commented on 2015-08-20 00:03

Switched to CMAKE_INSTALL_PREFIX=/usr

HalosGhost commented on 2015-08-19 23:43

Please fix this ASAP: ❤

https://bugs.archlinux.org/index.php?do=details&task_id=46025