Package Details: websocketpp-git-dev 0.7.0.1685.19cad99-1

Git Clone URL: https://aur.archlinux.org/websocketpp-git-dev.git (read-only)
Package Base: websocketpp-git-dev
Description: C++/Boost Asio based websocket client/server library, Develop branch
Upstream URL: http://www.zaphoyd.com/websocketpp/
Licenses: BSD
Conflicts: websocketpp
Provides: websocketpp
Submitter: boteium
Maintainer: boteium
Last Packager: boteium
Votes: 0
Popularity: 0.000000
First Submitted: 2018-01-15 03:44
Last Updated: 2018-01-15 03:44

Dependencies (9)

Required by (9)

Sources (1)

Latest Comments

apetresc commented on 2018-10-18 19:47

Indeed, the current develop branch is completely borked due to the test suite error. Here's a patch to bring it up to master which is stable: https://gist.github.com/e095da6e50995d4bec33a0ceeec0be92

therob commented on 2018-09-10 08:23

I'm getting the same resuls/errors as juanrodgil:

error: in "exact_match": check env.res.get_header("Connection") == "upgrade" has failed [Upgrade != upgrade]

*** 1 failure is detected in the test module "hybi_13_processor"

Is this most likely an upstream issue perhaps?

juanrodgil commented on 2018-07-31 08:39

It faults to build with this error!!

~/.cache/pacaur/websocketpp-git-dev/src/websocketpp-git-dev/build/test/processors/test_hybi13_boost Running 36 test cases... test/processors/hybi13.cpp(142): error: in "exact_match": check env.res.get_header("Connection") == "upgrade" has failed [Upgrade != upgrade]

*** 1 failure is detected in the test module "hybi_13_processor"

Maybe related with this commit from 19 days ago: https://github.com/zaphoyd/websocketpp/commit/5c48a114f4061f279e203c5f861555573e736f58