Package Details: wayfire 0.7.1-2

Git Clone URL: (read-only, click to copy)
Package Base: wayfire
Description: 3D wayland compositor
Upstream URL:
Keywords: compositor wayland
Licenses: custom:MIT
Conflicts: wayfire-git
Submitter: aperez
Maintainer: aperez
Last Packager: aperez
Votes: 16
Popularity: 1.97
First Submitted: 2019-02-14 08:43
Last Updated: 2021-05-06 13:47

Sources (1)

Latest Comments

1 2 Next › Last »

firegem commented on 2021-05-08 02:08

Looks like this needs doctest as a makedepend now.

aperez commented on 2021-05-06 13:50

@Moo-Crumpus: fixed, thanks for the heads up!

Moo-Crumpus commented on 2021-05-06 12:22

sha256sums: wayfire-0.7.1.tar.xz One or more files did not pass the validity check!

acb_netsurfer commented on 2021-04-21 12:00

wayfire was updated to 0.7.1 to add support for wlroots-0.13.x. Suggest (1) changing package version to say 0.7.1, (2) change wlroots dependencies to versions between 0.13 and 0.14, and (3) update the checksum (which can be acquired using makepkg -g). Users can do this manually until aperez implements the changes. These are all developments as of this week, so I wouldn't give aperez too hard of a time. If you aren't comfortable with modifying the PKGBUILD file, then install wlroots-0.12.0-1 from the archives

simona commented on 2021-04-16 15:25

:: l'installazione di wlroots (0.13.0-1) interrompe la dipendenza 'wlroots<0.13' richiesta da wayfire

stianz0 commented on 2021-02-07 22:31

I get error in the latest release, . I don't know why it fails to build tho, everything else are updated and fine.

fluix commented on 2020-11-08 19:16

I believe the license should be just MIT, not custom:MIT 1, similar to wayfire-git. This is probably unimportant, but I think quoting extra placing entries like the url, packages in (make)depends, etc. is also common.

oech3 commented on 2020-09-24 18:11

fails to build if -fuse-ld=lld in CFLAGS,CXXFLAGS.

dlupi commented on 2020-05-24 07:28

Compilation error of wf-config-0.4.0:

[2/30] Compiling C++ object 'wf-config@sha/src_section.cpp.o' FAILED: wf-config@sha/src_section.cpp.o c++ -Iwf-config@sha -I. -I../wf-config-0.4.0 -Iinclude -I../wf-config-0.4.0/include -I/usr/include/libevdev-1.0/ -I/usr/include/libxml2 -flto -fdiagnostics-color=always -pipe -D_FILE_OFFSET_BITS=64 -std=c++17 -Wno-deprecated-declarations -march=x86-64 -mtune=generic -O2 -fno-plt -D_FORTIFY_SOURCE=2 -fPIC -MD -MQ 'wf-config@sha/src_section.cpp.o' -MF 'wf-config@sha/src_section.cpp.o.d' -o 'wf-config@sha/src_section.cpp.o' -c ../wf-config-0.4.0/src/section.cpp ../wf-config-0.4.0/src/section.cpp: In member function ‘std::shared_ptr<wf::config::option_base_t> wf::config::section_t::get_option(const string&)’: ../wf-config-0.4.0/src/section.cpp:38:20: error: ‘invalid_argument’ is not a member of ‘std’ 38 | throw std::invalid_argument("Non-existing option " + name | ^~~~~~~~~~~~~~~~ ../wf-config-0.4.0/src/section.cpp: In member function ‘void wf::config::section_t::register_new_option(std::shared_ptr<wf::config::option_base_t>)’: ../wf-config-0.4.0/src/section.cpp:60:20: error: ‘invalid_argument’ is not a member of ‘std’ 60 | throw std::invalid_argument( | ^~~~~~~~~~~~~~~~ [7/30] Compiling C++ object 'wf-config@sha/src_file.cpp.o' ninja: build stopped: subcommand failed.

Plexcon commented on 2020-04-01 16:27

==> Missing dependencies: -> wf-config>=0.4 ==> Checking dependencies while compiling... ==> ERROR: Not all dependencies could be solved.