Package Details: waterfox-current-kpe 2020.07-0

Git Clone URL: https://aur.archlinux.org/waterfox-current-kpe.git (read-only, click to copy)
Package Base: waterfox-current-kpe
Description: Customizable privacy conscious web browser with better integration with KDE
Upstream URL: https://www.waterfox.net/
Keywords: firefox kwaterfox plasma waterfox-current-kde waterfox-kde
Licenses: MPL
Conflicts: waterfox-current
Provides: waterfox-current=2020.07
Replaces: waterfox-beta-kde
Submitter: hawkeye116477
Maintainer: hawkeye116477
Last Packager: hawkeye116477
Votes: 3
Popularity: 0.063336
First Submitted: 2019-11-11 22:08
Last Updated: 2020-07-01 19:18

Dependencies (41)

Required by (0)

Sources (9)

Pinned Comments

hawkeye116477 commented on 2019-09-12 19:31

Precompiled package with LTO+PGO and langpacks are available on my repository on OBS. More details at: https://build.opensuse.org/package/show/home:hawkeye116477:waterfox/waterfox-current-kpe.

Download at: https://software.opensuse.org//download.html?project=home%3Ahawkeye116477%3Awaterfox&package=waterfox-current-kpe .

If you got 404, then temporarily try to replace download.opensuse.org with downloadcontent.opensuse.org. That should enforce direct download without mirror.

Latest Comments

1 2 3 Next › Last »

SolarAquarion commented on 2020-03-15 13:58

you need to add git as a makedepend

hawkeye116477 commented on 2020-03-14 12:09

@Karrq Seems that's problem on your side or maybe GH works bad on night.... I did updpkgsums, even checked sums on local git repo and all are correct.

Karrq commented on 2020-03-14 00:32

The checksums are still failing, these are the values calculated:

  • a49c774f3077b0882d0a9672fadf1637894014ec916ead700375163f33672f9c waterfox-current.1
  • ff84e0de0332974b536ba42d4e16d911e489f6d7cbc2e51c57680c3d94ca5f7a vendor.js
  • 346b791515d05645be86e0f3404187e6397a22460ad54eb27aaf3054d81c2cd8 waterfox-current.desktop

I also checked the other files and their checksums are good

hawkeye116477 commented on 2020-03-13 17:24

Checksums are good, only was small typo, fixed.

Karrq commented on 2020-03-13 00:11

sha256sums of the following are failing...

  • waterfox-current.desktop
  • vendor.js
  • waterfox-current.1

I'm manually 'SKIP'ing them for now.

The package also fails to patch (patch: **** Can't open patch file ../current-kde-2020.03-xul.patch : No such file or directory). I noticed the patch is present but there's a typo in the PKGBUILD, as -xul is appended and not prepended to the version.

After fixing that the build fails when compiling servo

hawkeye116477 commented on 2020-02-29 08:37

@ranger Fixed.

ranger commented on 2020-02-27 21:39

pipewire is optional dep but without it I get:

$ waterfox-current XPCOMGlueLoad error for file /usr/lib/waterfox-current/libxul.so: libpipewire-0.2.so.1: cannot open shared object file: No such file or directory Couldn't load XPCOM.

I'm using x11 and installed the package from your link

hawkeye116477 commented on 2019-12-04 08:57

@kusoneko Thanks and sorry, I made a small cleanup recently on GH and apparently forgot that on aur there is still old link and needs to be changed.

kusoneko commented on 2019-12-04 04:11

@hawkeye116477 The PKGBUILD has an issue in the sources, for the patch mozilla-nongnome-proxies.patch it points to https://raw.githubusercontent.com/hawkeye116477/waterfox-deb/master/waterfox-beta/patches/mozilla-nongnome-proxies.patch which doesn't exist instead of I assume https://raw.githubusercontent.com/hawkeye116477/waterfox-deb/master/waterfox-current-kpe/patches/mozilla-nongnome-proxies.patch

hawkeye116477 commented on 2019-12-02 10:16

If someone had problem while building with Rust 1.39, I added patch now.