Package Details: warsaw 1.12.3.11-2

Git Clone URL: https://aur.archlinux.org/warsaw.git (read-only)
Package Base: warsaw
Description: Banking security tool developed by GAS Tecnologia
Upstream URL: https://seg.bb.com.br
Keywords: Banco BB Brasil Caixa CEF Econômica Federal Itau
Licenses: custom
Submitter: rafaelff
Maintainer: marieldejesus12
Last Packager: rafaelff
Votes: 39
Popularity: 0.000514
First Submitted: 2017-03-08 22:36
Last Updated: 2018-08-05 18:17

Latest Comments

1 2 3 4 5 6 ... Next › Last »

gerson commented on 2019-01-17 14:20

Só para constar uma sugestão, notei estes dias que o maldito Warsaw é responsável por deixar o boot do meu notebook significativamente mais lento. Então optei por desabilitar o serviço (systemctl disable warsaw), assim o warsaw não é inicializado no boot.

Atualmente uso o sistema do banco quase sempre no celular de qualquer forma. Então ligo o warsaw (systemctl start warsaw) só quando necessário. Note que uso o comando start, e não enable, para evitar que volte a inicializar no boot.

E seguimos torcendo para um dia os bancos largarem esta porquice! []s

nubiocicarini commented on 2018-12-25 13:15

Eu sigo estes passos para fazer funcionar o warsaw e sempre funciona. Espero que ajude.

++++ Passo-a-Passo Atualizado ++++ (15 de abril de 2018, por @esauvisky)

Siga as instruções abaixo antes de postar algum problema que estiver tendo com este pacote! ;)

1: Instale este PKGBUILD

2: Execute o workaround do @ArchHero para utilizar bibliotecas nativas:

$ cd /usr/lib/warsaw

sudo rm ld-linux-x86-64.so.2 && sudo ln -s /usr/lib/ld-linux-x86-64.so.2 .
sudo rm libc.so.6 && sudo ln -s /usr/lib/libc.so.6 .
sudo rm libpthread.so.0 && sudo ln -s /usr/lib/libpthread.so.0 .
sudo rm libdl.so.2 && sudo ln -s /usr/lib/libdl.so.2 .

3: Defina o atributo do diretório /usr/lib/warsaw como append-only:

sudo chattr +a /usr/lib/warsaw/

4: Ative e inicie o serviço do warsaw e execute core como usuário:

sudo systemctl enable warsaw
sudo systemctl start warsaw

$ /usr/bin/warsaw/core

Alternativamente você pode só dar enable no serviço e reiniciar o computador.

5: Verifique que os processos relacionados ao warsaw estão rodando corretamente:

$ ps aux | grep warsaw Você deve observar no mínimo 1 [...]/warsaw/core rodando como root e pelo menos um [...]/warsaw/wsatspi rodando como usuário.

Pode haver um core rodando como usuário também ou múltiplas instâncias de algum dos binários.

6: Certifique-se que seu navegador está configurado corretamente:

No caso do Chrome, é necessário ativar a flag: chrome://flags/#allow-insecure-localhost

No caso do Firefox, pode ser necessário clicar no ícone ao lado do cadeado e permitir a execução de applets flash.

bgualda commented on 2018-11-02 12:15

Pessoal, fui atualizar o pacote e ocorreu um crash no momento do update. Não estou conseguindo atualizar mais, e quando tempo remover os arquivos do path /usr/lib/warsaw ocorre que da a mensagem que não tenho permissão, mesmo executando como sudo.

Ao executar o comando lsattr observei que os arquivos estão marcado com um atributo 'e', conforme apresentado abaixo.

--------------e---- libm.so.6

Pelo que pude verificar na documentação do chattr esse atributo pertence a um bloco do sistema, mas não entendi o motivo.

   The 'e' attribute indicates that the file is using extents for mapping the blocks on disk.  It may not be removed using chattr(1).

Alguém sabe como resolver ?

marieldejesus12 commented on 2018-09-18 20:31

Galera, assumi o pacote, vou dar uma atualizada em alguns dias...

Se alguém quiser colar junto e virar mantenedor só falar...

potuz commented on 2018-08-25 18:29

Consegui resolver um dos erros, o /var/run/shm estava com modo 774 e não 777. Outro é que no meu systema o umask é 27, então os links em /usr/local/etc... tem que explicitamente mudar de bits. Agora consigo executar o core como usuário normal, mas ainda assim não consigo atualizar. Esse malware é uma praga.

potuz commented on 2018-08-25 16:21

Estava funcionando bem aqui até a ultima atualização e parou de funcionar. Agradeço alguma ajuda se vocês já tiveram essa situaçao:

1) O erro no banco do Brasil é "W03" 2) O https://www.dieboldnixdorf.com.br/warsaw reconhece que está instalado o warsaw mas não faz a atualização 3) Posso correr "core" como root, mas tanto "core" como "wsatspi" retornam com codigo de erro 127 como usuario normal 4) local.cfg tem tamanho 0 e nunca nada é escrito.

gerson commented on 2018-08-09 00:17

Acabei de testar o outro pacote warsaw-bin. Funcionou no Banco do Brasil. Após a instalação rodar:

systemctl enable warsaw

systemctl start warsaw

talesam commented on 2018-08-07 20:16

Atualizado: https://talesam.org/2017/03/14/instalando-o-modulo-de-seguranca-banco-brasil-warsaw/

rafaelff commented on 2018-08-05 18:19

Ok. Só "atualizei" o PKGBUILD removendo meu nome, pois não sou mantenedor dele.

Recomendo que alguém assuma manutenção desse pacote e aplique melhorias e correções que atendam a todos.

piussj2 commented on 2018-08-05 17:13

eu uso tenho que usar senão nem eu, nem meus clientes conseguem entrar no bb não exclui não, é um pacote útil