Package Details: wammu 0.44-14

Git Clone URL: https://aur.archlinux.org/wammu.git (read-only, click to copy)
Package Base: wammu
Description: A wxPython-based GUI for Gammu, a mobile phone manager.
Upstream URL: https://wammu.eu/wammu/
Licenses: GPL
Submitter: dreieck
Maintainer: dreieck
Last Packager: dreieck
Votes: 2
Popularity: 0.162597
First Submitted: 2021-01-23 16:56
Last Updated: 2021-10-18 12:28

Dependencies (7)

Required by (0)

Sources (1)

Latest Comments

df8oe commented on 2021-10-18 11:42

Hi, thanks for this additional information. I can build wammu now without any problems. :)

dreieck commented on 2021-10-18 11:18

It needs python2-pybluez 0.22. Version 0.23 in fact seems to be only python3 at the end.

Then wammu builds and the errors reported on 2021-01-23, 2021-03-30, 2021-04-24 seem to disappear.

I specified a version restriction in the makedepends-array.

And I adopted python2-pybluez and downgraded it to version 0.22.

dreieck commented on 2021-04-24 12:00

I have no ideas how to sort out the errors. If anyone has: Drop a note and feel free to adopt (I can orphan then).

df8oe commented on 2021-04-24 11:14

same error as risto3 has here...

dreieck commented on 2021-03-30 10:36

@risto3: I can confirm, although I get different error:

[...]
Checking for python-gammu ... found version 2.12 using Gammu 1.42.0 ... OK
/usr/lib/python2.7/site-packages/wx-3.0-gtk3/wx/_core.py:16629: UserWarning: wxPython/wxWidgets release number mismatch
  warnings.warn("wxPython/wxWidgets release number mismatch")
Checking for wxPython ... found version 3.0.2.0 ... OK
Checking for Bluetooth stack ...
Traceback (most recent call last):
  File "setup.py", line 501, in <module>
    **addparams
  File "/usr/lib/python2.7/site-packages/setuptools/__init__.py", line 162, in setup
    return distutils.core.setup(**attrs)
  File "/usr/lib/python2.7/distutils/core.py", line 151, in setup
    dist.run_commands()
  File "/usr/lib/python2.7/distutils/dist.py", line 953, in run_commands
    self.run_command(cmd)
  File "/usr/lib/python2.7/distutils/dist.py", line 972, in run_command
    cmd_obj.run()
  File "/usr/lib/python2.7/site-packages/setuptools/command/install.py", line 61, in run
    return orig.install.run(self)
  File "/usr/lib/python2.7/distutils/command/install.py", line 563, in run
    self.run_command('build')
  File "/usr/lib/python2.7/distutils/cmd.py", line 326, in run_command
    self.distribution.run_command(command)
  File "/usr/lib/python2.7/distutils/dist.py", line 972, in run_command
    cmd_obj.run()
  File "setup.py", line 330, in run
    self.check_requirements()
  File "setup.py", line 308, in check_requirements
    import bluetooth
  File "/usr/lib/python2.7/site-packages/bluetooth/__init__.py", line 282, in <module>
    """
AttributeError: attribute '__doc__' of 'instancemethod' objects is not writable

Thanks for reporting!

risto3 commented on 2021-01-23 17:32

compile problem for 0.44-4...

Checking for python-gammu ... found version 2.12 using Gammu 1.42.0 ... OK
18:29:45: Warning: Mismatch between the program and library build versions detected.
The library used 3.0 (wchar_t,compiler with C++ ABI 1014,wx containers,compatible with 2.8),
and wxPython used 3.0 (wchar_t,compiler with C++ ABI 1013,wx containers,compatible with 2.8).
Checking for wxPython ... found version 4.0.7.post2 ...
Traceback (most recent call last):
  File "setup.py", line 501, in <module>
    **addparams
  File "/usr/lib/python2.7/site-packages/setuptools/__init__.py", line 162, in setup
    return distutils.core.setup(**attrs)
  File "/usr/lib/python2.7/distutils/core.py", line 151, in setup
    dist.run_commands()
  File "/usr/lib/python2.7/distutils/dist.py", line 953, in run_commands
    self.run_command(cmd)
  File "/usr/lib/python2.7/distutils/dist.py", line 972, in run_command
    cmd_obj.run()
  File "/usr/lib/python2.7/site-packages/setuptools/command/install.py", line 61, in run
    return orig.install.run(self)
  File "/usr/lib/python2.7/distutils/command/install.py", line 563, in run
    self.run_command('build')
  File "/usr/lib/python2.7/distutils/cmd.py", line 326, in run_command
    self.distribution.run_command(command)
  File "/usr/lib/python2.7/distutils/dist.py", line 972, in run_command
    cmd_obj.run()
  File "setup.py", line 330, in run
    self.check_requirements()
  File "setup.py", line 295, in check_requirements
    elif not wx.USE_UNICODE:
AttributeError: 'module' object has no attribute 'USE_UNICODE'