Package Details: wallch 4.15-4

Git Clone URL: https://aur.archlinux.org/wallch.git (read-only)
Package Base: wallch
Description: A powerful general purpose wallpaper changer.
Upstream URL: https://melloristudio.com/wallch/
Keywords: Desktop Melloristudio Wallch Wallpaper
Licenses: GPL3
Provides: wallch
Submitter: juanmah
Maintainer: vwugd97
Last Packager: vwugd97
Votes: 18
Popularity: 0.000000
First Submitted: 2012-04-27 15:39
Last Updated: 2016-04-01 18:28

Latest Comments

« First ‹ Previous 1 2 3 Next › Last »

Anonymous comment on 2014-07-19 14:06

Is there really no one that can get it to compile? I've mailed the developer but they do not have the knowledge (packages and arch linux) nor the time to help us out.

This is the newest version: http://sourceforge.net/projects/wall-changer/files/wallch_4.15.tar.gz/download

juanmah commented on 2014-06-13 17:34

Please find a way to compile it! THX!

berot3 commented on 2014-06-13 12:48

Please update to 4.0! THX!
from http://melloristudio.com/wallch/ : "Notice that Wallch 4.0 is the recommended version to download."

juanmah commented on 2014-04-29 05:52

jaro3. I'm in this dead end too.

jaro3 commented on 2014-04-28 07:33

Doesn't compile on current Arch due to update to libicuuc.so.53:

/usr/bin/ld: warning: libicui18n.so.52, needed by /usr/lib/libdee-1.0.so, not found (try using -rpath or -rpath-link)
/usr/bin/ld: warning: libicuuc.so.52, needed by /usr/lib/libdee-1.0.so, not found (try using -rpath or -rpath-link)
/usr/bin/ld: warning: libicudata.so.52, needed by /usr/lib/libdee-1.0.so, not found (try using -rpath or -rpath-link)
/usr/lib/libdee-1.0.so: undefined reference to `utrans_openU_52'
/usr/lib/libdee-1.0.so: undefined reference to `utrans_close_52'
/usr/lib/libdee-1.0.so: undefined reference to `u_errorName_52'
/usr/lib/libdee-1.0.so: undefined reference to `u_strFromUTF8Lenient_52'
/usr/lib/libdee-1.0.so: undefined reference to `utrans_transUChars_52'
collect2: error: ld returned 1 exit status
Makefile:154: recipe for target 'wallch' failed
make: *** [wallch] Error 1

If PKGBUILD changed to newest version 4.0, compilation also crashes with ERROR:

In file included from src/about.cpp:26:0:
src/glob.h:36:26: fatal error: QStandardPaths: No such file or directory
#include <QStandardPaths>
^
compilation terminated.
Makefile:445: recipe for target 'about.o' failed
make: *** [about.o] Error 1

----------------

installed all qt5 packages but no help :-(

juanmah commented on 2014-01-19 15:12

Thx DoobieUs. Fixed

DoobieUs commented on 2014-01-19 00:09

Note that for now (Jan 2014) the PKGBUILD tries to download wallch-XX.YY instead of wallch_XX.YY.

To fix, edit the source property in PKGBUILD

from:

${pkgname}-${pkgver}.tar.gz

to

${pkgname}_${pkgver}.tar.gz

juanmah commented on 2013-04-09 11:09

Patched

juanmah commented on 2013-04-09 11:02

Makefile must be patched

juanmah commented on 2013-04-09 10:59

It fails at packaging, because install uses lrelease from qt3:

lrelease[...]
Usage:
lrelease [options] project-file
lrelease [options] ts-files [-qm qm-file]
Options:
-help Display this information and exit
-nocompress
Do not compress the .qm files
-verbose
Explain what is being done
-version
Display the version of lrelease and exit
make: *** [install_configfiles] Error 1
==> ERROR: A failure occurred in package().
Aborting...