Package Details: vrk-mpollux-digisign-client 1:4.1.0_7399-1

Git Clone URL: https://aur.archlinux.org/vrk-mpollux-digisign-client.git (read-only, click to copy)
Package Base: vrk-mpollux-digisign-client
Description: Client program for Finnish chip ID cards
Upstream URL: https://dvv.fi/linux-versiot
Keywords: smartcard
Licenses: custom
Submitter: Atte
Maintainer: ple
Last Packager: ple
Votes: 4
Popularity: 0.33
First Submitted: 2013-09-19 13:14
Last Updated: 2020-03-04 21:41

Latest Comments

Wild_Penguin commented on 2020-04-04 10:17

Hi,

I'm a bit surprised people can use this software at all. Commenting here though maybe a better place would be to contact vrk or the Arch forums, but possibly vrk would evade questions by complaining about "unsupported distribution", and as this is a closed source blob...

First, the script (/bin/DigiSignApplication) supposed to run the mPollux client kills itself on line 17. Although the killall -line has .bin at the end, process names are truncated at 15 characters, so the line will kill the script. They should have used something like lock and PID files to handle this! Although it might work in some situations / distributions, as we can see here, using killall this way is very error prone and hacky...

Moreover, the checks at the beginning check for empty strings [ -z $HOME... ], but of course that doesn't work as the strings are never empty. They're supposed to test [ ! -d ... ], i.e. a non-existing directory.

Workarounds: comment out the "killall" line and make the directories by hand or change the tests to [ ! -d ... ]. Just don't run two mPollux clients at the same time, as now the script won't kill the first one anymore.

jpalko commented on 2020-03-25 08:39

I think the documentation PDF's get left out now as when I did a fresh install and after compressing package it complains on not being able to translate pathnames for them. Also the /usr/share/doc/mpollux-digisign-client-for-vrk is not created on install.

ple commented on 2020-03-04 21:44

4.1.0 is here too now. Thanks for reminding me!

jpalko commented on 2020-03-04 10:58

4.1.0-7399 is available, url: https://dvv.fi/documents/16079645/17632618/Ubuntu_16.04.3_LTS_mpollux-digisign-client-for-vrk_4.1.0-7399_amd64.deb/b6c64e17-f2dc-a753-fd13-3cb290e7045f

Looks like they've switched to Qt5 now additionally: % ldd DigiSignApplication.bin | grep Qt libQt5Widgets.so.5 => /usr/lib/libQt5Widgets.so.5 (0x00007f4a7ae5d000) libQt5Gui.so.5 => /usr/lib/libQt5Gui.so.5 (0x00007f4a7a7b4000) libQt5Core.so.5 => /usr/lib/libQt5Core.so.5 (0x00007f4a7a27b000)

Atte commented on 2016-09-01 08:05

Package updated. Thanks for the heads-up!

jpalko commented on 2016-09-01 07:49

4.0.8-5448 is available, download url's:
https://eevertti.vrk.fi/documents/2634109/2857792/Ubuntu_14.04.2_LTS_mpollux-digisign-client-for-vrk_4.0.8-5448_amd64.deb/1594f580-fdbc-4b75-adc7-89798f09fe54
https://eevertti.vrk.fi/documents/2634109/2857792/Ubuntu_14.04.2_LTS_mpollux-digisign-client-for-vrk_4.0.8-5448_i386.deb/b6f2d459-f6c3-4d17-9741-5a4ba0a89948
@
https://eevertti.vrk.fi/linux-versiot