Package Details: vpn-unlimited 4.23-3

Git Clone URL: https://aur.archlinux.org/vpn-unlimited.git (read-only)
Package Base: vpn-unlimited
Description: VPN Unlimited client application
Upstream URL: https://www.vpnunlimitedapp.com
Keywords: unlimited-vpn unlimitedvpn vpn vpn-unlimited vpnunlimited
Licenses: custom:"Copyright (c) 2017 KeepSolid Inc."
Submitter: aytekinar
Maintainer: aytekinar
Last Packager: aytekinar
Votes: 6
Popularity: 0.013040
First Submitted: 2017-07-24 14:08
Last Updated: 2018-10-23 08:22

Latest Comments

« First ‹ Previous 1 2 3 4

Dinoraptor101 commented on 2018-01-07 17:42

Hello Aytekinar! Wow it worked the warning message was stopping operation until I ran the package in sudo.

  • sudo systemctl enable vpn-unlimited-daemon
  • reboot
  • sudo vpn-unlimited (for sighning in. required admin access)

Afterwards it worked fine :)

<hr>

Updated pkgsums as requested but I'm only a user, I have no write access into the AUR :)

md5sums_x86_64=('8623605b1bef9eda0f451a9b4447629f' 'eec970693be55274ff2e85e596407f20' '713c98161060b81c5c963e9aa51d1d82') md5sums_i686=('8623605b1bef9eda0f451a9b4447629f' 'eec970693be55274ff2e85e596407f20' '998dbdc5c67644c0adbb40584d5f62ca')

aytekinar commented on 2018-01-05 14:14

Thank you, Dinoraptor101, for your help :) After bumping the version, you need to run updpkgsums and makepkg --printsrcinfo > .SRCINFO to make the changes valid for submitting to AUR. Please see the Wiki for more information, and let me know if the bumped version works for you.

nikolak and alphancioglu, please confirm if the bumped version works for you two. The /usr/bin/vpn-unlimited-daemon: /usr/lib/libcurl-openssl-1.0.so: no version information available (required by /usr/lib/libvpnu_private_sdk.so.1) warning message does persist, but I do not seem to have any error messages and/or failures when I run the desktop app.

Dinoraptor101 commented on 2017-12-30 00:56

VPN 4.16 was released. I edited the version in the package but it's failing hash validation :) help is appreciated! sorry for noob-ness!

alphancioglu commented on 2017-12-21 13:46

After I start vpn-unlimited-daemon.service and run vpn-unlimited I get the following error on dialog window:

The access to VPN Unlimited servers is disabled because the related VPN Unlimited Host Service is currently stopped. Please restart the service. Read the instructions

I check the vpn-unlimited-daemon.service with "systemctl list-units" before running vpn-unlimited and it says "loaded active running". After I run vpn-unlimited it says "loaded failed failed". Following is the terminal output of vpn-unlimited:

/usr/share/vpn-unlimited/vpn-unlimited: /usr/lib/libcurl-openssl-1.0.so: no version information available (required by /usr/lib/libvpnu_rpc.so.1) Translation file loaded: ":/translations/translations/VPN_Unlimited_English.qm" Translation file loaded: ":/translations/translations/VPN_SDK_English.qm" libpng warning: iCCP: known incorrect sRGB profile libpng warning: iCCP: known incorrect sRGB profile libpng warning: iCCP: known incorrect sRGB profile libpng warning: iCCP: known incorrect sRGB profile libpng warning: iCCP: known incorrect sRGB profile libpng warning: iCCP: known incorrect sRGB profile libpng warning: iCCP: known incorrect sRGB profile sh: lsb_release: command not found propsReply "Method \"GetAll\" with signature \"s\" on interface \"org.freedesktop.DBus.Properties\" doesn't exist\n" nmReply "Method \"GetDevices\" with signature \"\" on interface \"org.freedesktop.NetworkManager\" doesn't exist\n" "Object path cannot be empty" sh: lsb_release: command not found sh: lsb_release: command not found libpng warning: iCCP: known incorrect sRGB profile libpng warning: iCCP: known incorrect sRGB profile libpng warning: iCCP: known incorrect sRGB profile libpng warning: iCCP: known incorrect sRGB profile libpng warning: iCCP: known incorrect sRGB profile libpng warning: iCCP: known incorrect sRGB profile libpng warning: iCCP: known incorrect sRGB profile libpng warning: iCCP: known incorrect sRGB profile libpng warning: iCCP: known incorrect sRGB profile libpng warning: iCCP: known incorrect sRGB profile libpng warning: iCCP: known incorrect sRGB profile libpng warning: iCCP: known incorrect sRGB profile libpng warning: iCCP: known incorrect sRGB profile libpng warning: iCCP: known incorrect sRGB profile libpng warning: iCCP: known incorrect sRGB profile libpng warning: iCCP: known incorrect sRGB profile libpng warning: iCCP: known incorrect sRGB profile libpng warning: iCCP: known incorrect sRGB profile "Unexpected reply signature: got \"\", expected \"a{sv}\"" libpng warning: iCCP: known incorrect sRGB profile "Unexpected reply signature: got \"\", expected \"a{sv}\"" "Unexpected reply signature: got \"\", expected \"a{sv}\"" "Unexpected reply signature: got \"\", expected \"a{sv}\"" "Unexpected reply signature: got \"\", expected \"a{sv}\""

aytekinar commented on 2017-12-19 12:17

Hey nikolak,

On my system, it does indeed work.

nikolak commented on 2017-12-19 11:52

Does this package still work?

I'm having problems starting it. It keeps crashing with a segfault.

aytekinar commented on 2017-10-01 19:00

Hey Dinoraptor101,

I couldn't understand why you needed to receive Daniel Stenberg's GPG key, but thank you for pointing out.

I would appreciate if you wrote what type of an error you got when you wanted to start vpn-unlimited-daemon. Normally, `sudo systemctl start vpn-unlimited-daemon` should work. Similarly, if you would like to enable it in start-up, please issue `sudo systemctl enable vpn-unlimited-daemon`.

Let me know if you run into problems so that I can try to fix it.

Dinoraptor101 commented on 2017-09-29 08:06

This helped!!
gpg --recv-keys --keyserver hkp://18.9.60.141 5CC908FDB71E12C2

However I'm unable to start vpn-unlimited-daemon, I couldn't start it manually with systemd, however it worked after I restarted the machine.

=====
I'm new to Arch Linux and I'm completely blown away by the AUR Repository and it's support! this changes everything!