Package Details: vorta 0.7.5-1

Git Clone URL: https://aur.archlinux.org/vorta.git (read-only, click to copy)
Package Base: vorta
Description: A GUI for BorgBackup
Upstream URL: https://github.com/borgbase/vorta
Keywords: backup borg
Licenses: GPL
Submitter: bjo
Maintainer: bjo
Last Packager: bjo
Votes: 30
Popularity: 2.80
First Submitted: 2018-11-19 21:33
Last Updated: 2021-03-03 08:14

Latest Comments

1 2 3 4 5 6 ... Next › Last »

bjo commented on 2021-02-27 10:01

The issue was caused by the python-pyqt5 package and it has been fixed: https://bugs.archlinux.org/task/69802

bjo commented on 2021-02-26 16:58

I was able to reproduce it now and created a issue: https://github.com/borgbase/vorta/issues/896 But IMHO it's still not clear if something is wrong with the python-pyqt5 package.

f0rdprefect commented on 2021-02-26 15:34

Yepp same here. downgrade works.

lfcr commented on 2021-02-26 10:17

Sorry, vorta 0.7.4 same problem. Only downgrade python-pyqt5-5.15.2-3 works.

dlandau commented on 2021-02-26 07:04

I tried installing the full pyqt5-group. It didn't help. In order to downgrade to python-pyqt5-5.15.2 I had to first uninstall python-pyqt5-networkauth that got pulled in from the group and had conflicting files with the older version. After that vorta works again.

igno2k commented on 2021-02-25 20:31

Same here - works fine with python-pyqt5-5.15.2 (after downgrading from python-pyqt5-5.15.3)

bjo commented on 2021-02-25 15:55

I can't reproduce the issue. can you check if rebuilding helps?

bjo commented on 2021-02-25 12:55

Strange, I will take a look later. Does it help if you install the whole pyqt5-group?

dlandau commented on 2021-02-25 12:44

python-pyqt5 5.15.3-1 here, same issue (error message again for formatting)

Traceback (most recent call last):
  File "/usr/bin/vorta", line 33, in <module>
    sys.exit(load_entry_point('vorta==0.7.3', 'gui_scripts', 'vorta')())
  File "/usr/bin/vorta", line 25, in importlib_load_entry_point
    return next(matches).load()
  File "/usr/lib/python3.9/importlib/metadata.py", line 77, in load
    module = import_module(match.group('module'))
  File "/usr/lib/python3.9/importlib/__init__.py", line 127, in import_module
    return _bootstrap._gcd_import(name[level:], package, level)
  File "<frozen importlib._bootstrap>", line 1030, in _gcd_import
  File "<frozen importlib._bootstrap>", line 1007, in _find_and_load
  File "<frozen importlib._bootstrap>", line 986, in _find_and_load_unlocked
  File "<frozen importlib._bootstrap>", line 680, in _load_unlocked
  File "<frozen importlib._bootstrap_external>", line 790, in exec_module
  File "<frozen importlib._bootstrap>", line 228, in _call_with_frames_removed
  File "/usr/lib/python3.9/site-packages/vorta/__main__.py", line 9, in <module>
    from vorta.models import init_db
  File "/usr/lib/python3.9/site-packages/vorta/models.py", line 17, in <module>
    from vorta.utils import slugify
  File "/usr/lib/python3.9/site-packages/vorta/utils.py", line 23, in <module>
    from vorta.borg._compatibility import BorgCompatibility
  File "/usr/lib/python3.9/site-packages/vorta/borg/_compatibility.py", line 1, in <module>
    from pkg_resources import parse_version
  File "/usr/lib/python3.9/site-packages/pkg_resources/__init__.py", line 3243, in <module>
    def _initialize_master_working_set():
  File "/usr/lib/python3.9/site-packages/pkg_resources/__init__.py", line 3226, in _call_aside
    f(*args, **kwargs)
  File "/usr/lib/python3.9/site-packages/pkg_resources/__init__.py", line 3255, in _initialize_master_working_set
    working_set = WorkingSet._build_master()
  File "/usr/lib/python3.9/site-packages/pkg_resources/__init__.py", line 568, in _build_master
    ws.require(__requires__)
  File "/usr/lib/python3.9/site-packages/pkg_resources/__init__.py", line 886, in require
    needed = self.resolve(parse_requirements(requirements))
  File "/usr/lib/python3.9/site-packages/pkg_resources/__init__.py", line 772, in resolve
    raise DistributionNotFound(req, requirers)
pkg_resources.DistributionNotFound: The 'PyQt5-Qt>=5.15' distribution was not found and is required by pyqt5

bjo commented on 2021-02-25 12:10

Which version of python-pyqt5 do you have?