Package Details: volctl 0.6.2-2

Git Clone URL: https://aur.archlinux.org/volctl.git (read-only)
Package Base: volctl
Description: Per-application volume control for GNU/Linux desktops
Upstream URL: https://buzz.github.io/volctl/
Keywords: desktop pulseaudio tray volume
Licenses: GPL
Submitter: buzz
Maintainer: buzz
Last Packager: buzz
Votes: 9
Popularity: 0.29
First Submitted: 2016-04-22 16:53
Last Updated: 2019-08-11 08:32

Latest Comments

buzz commented on 2019-12-01 11:32

I'm getting the error DistributionNotFound: The 'volctl==0.6.2' distribution was not found and is required by the application. Any idea as for why?

Smells like you recently upgraded to Python 3.8 and volctl is still installed for 3.7? Try reinstalling volctl.

Icemole commented on 2019-12-01 10:35

I'm getting the error DistributionNotFound: The 'volctl==0.6.2' distribution was not found and is required by the application. Any idea as for why?

Output of $ volctl:

Traceback (most recent call last): File "/usr/bin/volctl", line 6, in <module> from pkg_resources import load_entry_point File "/usr/lib/python3.8/site-packages/pkg_resources/__init__.py", line 3252, in <module> def _initialize_master_working_set(): File "/usr/lib/python3.8/site-packages/pkg_resources/__init__.py", line 3235, in _call_aside f(*args, **kwargs) File "/usr/lib/python3.8/site-packages/pkg_resources/__init__.py", line 3264, in _initialize_master_working_set working_set = WorkingSet._build_master() File "/usr/lib/python3.8/site-packages/pkg_resources/__init__.py", line 583, in _build_master ws.require(__requires__) File "/usr/lib/python3.8/site-packages/pkg_resources/__init__.py", line 900, in require needed = self.resolve(parse_requirements(requirements)) File "/usr/lib/python3.8/site-packages/pkg_resources/__init__.py", line 786, in resolve raise DistributionNotFound(req, requirers) pkg_resources.DistributionNotFound: The 'volctl==0.6.2' distribution was not found and is required by the application

MrThePaul commented on 2019-04-29 17:42

This package requires python-setuptools to be installed but does not declare this dependency.

buzz commented on 2016-05-03 16:14

Thanks for the feedback!

I wasn't aware of this.

TrialnError commented on 2016-05-03 16:04

Few comments about the PKGBUILD.
* Per guideline empty vars should be removed.
* The install file isn't needed anymore. Since pacman5 and its hook support made it obsolete. desktop-file-utils includes now a hook, which does the update, whenever a package installs a file there.