Package Details: vmware-vsphere-web-client-plugin 6.2.0-4

Git Clone URL: https://aur.archlinux.org/vmware-vsphere-web-client-plugin.git (read-only)
Package Base: vmware-vsphere-web-client-plugin
Description: Firefox and Chromium plugin, to access virtual machines console from vSphere Web Client.
Upstream URL: http://www.vmware.com/
Licenses: custom:vmware
Submitter: ReNoM
Maintainer: paul.wilk
Last Packager: paul.wilk
Votes: 22
Popularity: 0.000130
First Submitted: 2013-04-19 10:26
Last Updated: 2018-02-20 15:53

Dependencies (4)

Required by (0)

Sources (1)

Latest Comments

« First ‹ Previous 1 2 3 4 5 6 Next › Last »

ReNoM commented on 2014-06-18 09:50

updated.

cros13 commented on 2014-06-15 00:01

it's backwards compatible

jvybihal commented on 2014-06-05 11:32

Or maybe it's backwards compatible?

jvybihal commented on 2014-06-05 11:32

It would be cool, if this became up-to-date package, and someone created vmware-vsphere-web-client-plugin51, since I believe many people are still on 5.1 version.

xanthi commented on 2014-06-05 11:26

Happy to take over as maintainer if ReNoM is no longer updating this. There's another update to 5.5.0 (ships with 5.5.0u1) since billybigrigger posted the below PKGBUILD.

billybigrigger commented on 2014-04-11 21:18

Hi, I've have fixed up and built an x86_64 package for 5.5, as I couldn't find an 32bit .bundle. Here is were I found the bundle. https://download.iseage.org/vmware-plugin/

PKGBUILD
--------

# Contributor: ReNoM <renom@list.ru>
pkgname=vmware-vsphere-web-client-plugin
pkgver=5.5.0
pkgrel=1
pkgdesc="Firefox and Chromium plugin, to access virtual machines console from vSphere Web Client. For make package, place VMware-ClientIntegrationPlugin-5.5.0.{your_arch}.bundle to PKGBUILD directory."
arch=('x86_64')
url="http://www.vmware.com/"
license=('custom:vmware')
depends=(mozilla-common)
[ "$CARCH" == "x86_64" ] && source=(VMware-ClientIntegrationPlugin-5.5.0.x86_64.bundle) && bundle_arch=x86_64 && larch=64

[ "$CARCH" == "x86_64" ] && md5sums=('6f040cbc4f5e3b3178bfe48c665b0d81')

build() {
cd "$srcdir"
sh ../VMware-ClientIntegrationPlugin-5.5.0.${bundle_arch}.bundle -x files
}

package ()
{
cd "$pkgdir"
mkdir -p usr/lib/vmware-cip/5.5/
mkdir -p usr/lib/vmware-vmrc/5.5/
mkdir -p usr/lib${larch}/mozilla/plugins
mkdir -p etc/vmware-vmrc/5.5
echo "libdir = \"/usr/lib/vmware-vmrc/5.5\"" > etc/vmware-vmrc/5.5/config
# install cip
install ${srcdir}/files/vmware-cip-55/npVMwareClientSupportPlugin-5-5-0.so "usr/lib/vmware-cip/5.5/"
mv "$srcdir/files/vmware-cip-55/artwork" "usr/lib/vmware-cip/5.5/"
mv "$srcdir/files/vmware-cip-55/filetransfer" "usr/lib/vmware-cip/5.5/"
chmod +x "usr/lib/vmware-cip/5.5/filetransfer/fileTransfer"
mv "$srcdir/files/vmware-cip-55/ovftool" "usr/lib/vmware-cip/5.5/"
chmod +x "usr/lib/vmware-cip/5.5/ovftool/ovftool"
chmod +x "usr/lib/vmware-cip/5.5/ovftool/ovftool.bin"
ln -s "/usr/lib/vmware-cip/5.5/npVMwareClientSupportPlugin-5-5-0.so" "usr/lib$larch/mozilla/plugins/npVMwareClientSupportPlugin-5-5-0.so"
# install vmrc
install "$srcdir/files/vmware-vmrc-5.5/np-vmware-vmrc-5.5.0-1280474-32.so" "usr/lib/vmware-vmrc/5.5/"
install "$srcdir/files/vmware-vmrc-5.5/np-vmware-vmrc-5.5.0-1280474-64.so" "usr/lib/vmware-vmrc/5.5/"
install "$srcdir/files/vmware-vmrc-5.5/np-vmware-vmrc.so" "usr/lib/vmware-vmrc/5.5/"
install "$srcdir/files/vmware-vmrc-5.5/open_source_licenses.txt" "usr/lib/vmware-vmrc/5.5/"
install "$srcdir/files/vmware-vmrc-5.5/version.txt" "usr/lib/vmware-vmrc/5.5/"
install "$srcdir/files/vmware-vmrc-5.5/vmware-desktop-entry-creator" "usr/lib/vmware-vmrc/5.5/"
mv "$srcdir/files/vmware-vmrc-5.5/bin" "usr/lib/vmware-vmrc/5.5/"
chmod -R +x "usr/lib/vmware-vmrc/5.5/bin/"
mv "$srcdir/files/vmware-vmrc-5.5/lib" "usr/lib/vmware-vmrc/5.5/"
mv "$srcdir/files/vmware-vmrc-5.5/libconf" "usr/lib/vmware-vmrc/5.5/"
mv "$srcdir/files/vmware-vmrc-5.5/share" "usr/lib/vmware-vmrc/5.5/"
mv "$srcdir/files/vmware-vmrc-5.5/xkeymap" "usr/lib/vmware-vmrc/5.5/"
ln -s /usr/lib/vmware-vmrc/5.5/np-vmware-vmrc-5.5.0-1280474-${larch}.so usr/lib${larch}/mozilla/plugins/np-vmware-vmrc-5.5.0-1280474-${larch}.so
ln -s /usr/lib/vmware-vmrc/5.5/bin/appLoader usr/lib/vmware-vmrc/5.5/bin/vmware-deviceMgr
ln -s /usr/lib/vmware-vmrc/5.5/bin/appLoader usr/lib/vmware-vmrc/5.5/bin/vmware-vmrc
ln -s /usr/lib/vmware-vmrc/5.5/bin/appLoader usr/lib/vmware-vmrc/5.5/bin/vmware-vmrc-daemon
ln -s /usr/lib/vmware-vmrc/5.5/bin/vmware-deviceMgr usr/lib/vmware-vmrc/5.5/vmware-deviceMgr
ln -s /usr/lib/vmware-vmrc/5.5/bin/vmware-vmrc usr/lib/vmware-vmrc/5.5/vmware-vmrc
ln -s /usr/lib/vmware-vmrc/5.5/bin/vmware-vmrc-daemon usr/lib/vmware-vmrc/5.5/vmware-vmrc-daemon
}

ReNoM commented on 2014-04-09 05:54

ryanc, no.

ryanc commented on 2014-04-08 17:34

@ReNoM, Did you get a copy of the 5.5 bundle?

ReNoM commented on 2014-03-12 06:21

Yes, I need bundle.

bararchy commented on 2014-03-09 12:58

Version 5.5 is out, if you need the bundle to change the script tell me