Package Details: vmware-vsphere-web-client-plugin 6.2.0-4

Git Clone URL: https://aur.archlinux.org/vmware-vsphere-web-client-plugin.git (read-only)
Package Base: vmware-vsphere-web-client-plugin
Description: Firefox and Chromium plugin, to access virtual machines console from vSphere Web Client.
Upstream URL: http://www.vmware.com/
Licenses: custom:vmware
Submitter: ReNoM
Maintainer: paul.wilk
Last Packager: paul.wilk
Votes: 22
Popularity: 0.000123
First Submitted: 2013-04-19 10:26
Last Updated: 2018-02-20 15:53

Dependencies (4)

Required by (0)

Sources (1)

Latest Comments

« First ‹ Previous 1 2 3 4 5 6 Next › Last »

jstjohn commented on 2014-12-02 05:31

I am still having the problem I posted about before on 2014-10-15 01:37. makepkg can find the bundle file and starts running the bundle script, but it keeps returning an error about "magic number does not match".

Has anyone been able to successfully build this? If so, can you please post your PKGBUILD if it differs from the one on the AUR here?

jstjohn commented on 2014-12-02 05:23

@gps1539: There seems to be a problem with your PKGBUILD. You were referencing the 64-bit version earlier, and most recently, your error is referencing the 32-bit version. Check the "larch" variable and make sure it is set to the correct value.

gps1539 commented on 2014-11-28 19:47

Thanks again for the help.

The installs now starts, but fails as the checksum is wrong. Editing PKGBUILD and updating the checksum, gets the install to get further, but it turn fails src files are missing

==> Starting package()...
install: cannot stat ‘/tmp/yaourt-tmp-grahams/aur-vmware-vsphere-web-client-plugin/src/files/vmware-vmrc-5.5/np-vmware-vmrc-5.5.0-1896274-32.so’: No such file or directory
==> ERROR: A failure occurred in package().
Aborting...
==> ERROR: Makepkg was unable to build vmware-vsphere-web-client-plugin.

The client I'm trying to install is for vCenter 5.5 update 2. I'm guessing the package needs updating for that.

pezz commented on 2014-11-27 22:43

For yaourt (I use it too), it needs to go in:

/tmp/yaourt-tmp-<user>/<package-name>

gps1539 commented on 2014-11-27 16:51

@pezz

Thanks for the reply. I'm using yaourt and its default build directory is /tmp. I copied the bundle to /tmp, but the install still fails with

ERROR: VMware-ClientIntegrationPlugin-5.5.0.x86_64.bundle was not found in the build directory and is not a URL.

# ls -l /tmp/VMware-ClientIntegrationPlugin-5.5.0.x86_64.bundle
-rwxrwxrwx 1 grahams grahams 83810225 27.11.2014 08:32 /tmp/VMware-ClientIntegrationPlugin-5.5.0.x86_64.bundle*

Are others able to install the plugin?

pezz commented on 2014-11-27 03:23

You have to put the .bundle file in the directory your AUR helper uses to build stuff.

You get the bundle by going to the Web Client login screen and clicking the download link.

gps1539 commented on 2014-11-27 01:07

@jstjohn

I get the same error with no such file or directory. It seems to not be downloading the plugin from vmware.com

jstjohn commented on 2014-10-15 01:37

Is anyone getting the following error when trying to build this?

---------
==> Starting build()...
sh: ../VMware-ClientIntegrationPlugin-5.5.0.x86_64.bundle: No such file or directory
---------

When I remove the "../" from the build function, I no longer get that error, but I get the following error instead:

---------
==> Starting build()...
magic number does not match
---------

I have no idea why the magic number isn't matching... The bundle states that non-GNU stat will cause problems, but according to stat(1) and pacman, I'm using GNU stat from the "coreutils" package in [core].

pezz commented on 2014-10-01 03:17

Temp PKGBUILD for anyone that wants it, for vSphere Web Client Version 5.5.0 Build 2026576.

https://raw.githubusercontent.com/pezz/aur/master/vmware-vsphere-web-client-plugin/PKGBUILD

NB: I've only updated the md5sums for x86_64, and fixed the library versions.

gps1539 commented on 2014-07-16 19:57

Where is the PKGBUILD directory going to be located for this? thanks