Package Details: vmware-patch 15.5.1-1

Git Clone URL: https://aur.archlinux.org/vmware-patch.git (read-only, click to copy)
Package Base: vmware-patch
Description: A post-install configuration solution for VMware Workstation (Pro) and Player (Plus and Pro)
Upstream URL: https://wiki.archlinux.org/index.php/VMware#Configuration
Keywords: patch vmci vmmon vmnet vmware
Licenses: GPL
Submitter: oliv
Maintainer: None
Last Packager: lfleischer
Votes: 208
Popularity: 0.27
First Submitted: 2011-01-31 12:49
Last Updated: 2019-11-23 15:07

Required by (0)

Sources (41)

Latest Comments

« First ‹ Previous 1 2 3 4 5 6 7 8 9 10 ... Next › Last »

bararchy commented on 2017-10-01 13:09

Can you please add a fix to the memory issue ?

Vmware forum: https://communities.vmware.com/thread/571370
patch: https://github.com/mkubecek/vmware-host-modules/commit/fadedd9c8a4d
arch forum: https://bbs.archlinux.org/viewtopic.php?id=230412

warmarchie commented on 2017-10-01 13:08

Will this get VMware up and running with 4.13? If not what is the best course of action other than waiting? Trying to downgrade kernel+modules?

nottin commented on 2017-09-28 04:08

patching file vmmon-only/linux/hostif.c
Hunk #1 FAILED at 1162.
1 out of 1 hunk FAILED -- saving rejects to file vmmon-only/linux/hostif.c.rej
==> error: Failed to apply 'vmmon-12.5.2-4.9.patch'

uname -r
4.12.13-1-ARCH

darky commented on 2017-09-26 21:47

==> Verifying source file signatures with gpg...
ncurses-6.0-20170902.tgz ... FAILED (unknown public key 702353E0F7E48EDB)
==> ERROR: One or more PGP signatures could not be verified!

khau commented on 2017-09-25 05:01

Will this also require ams1's and orson's patches?
I'm away from my computer but will test the new patch as soon as I can. Thanks for the update!

rains commented on 2017-09-16 13:54

patch for kernel 4.13 has been added.
refer to https://communities.vmware.com/thread/568089

% sudo vmware-patch -f
==> Patching VMware Workstation Pro v12.5.7 for kernel 4.13.1-1-ARCH..
-> [vmnet]
==> Installing modules..
-> Done.
sudo vmware-patch -f 21.19s user 3.07s system 172% cpu 14.034 total

alekssaul commented on 2017-09-06 21:42

same issue as @khau.

# uname -r
4.12.10-1-ARCH

# ls /usr/lib/modules
4.12.10-1-ARCH/

can't find `version.h`. Upgraded to VMware-Workstation-Full-12.5.7-5813279.x86_64.bundle which fixed that issue, also had to downgrade to libpng-1.6.28-1-x86_64.pkg.tar.xz

khau commented on 2017-09-05 17:17

@rains
My apologies - I wasn't notified of your response.
# uname -r
# 4.12.8-2-ARCH
#
# ls /usr/lib/modules
# 4.12.8-2-ARCH extramodules-4.12-ARCH

The problem persists across restarts. Please let me know if I can supply any more information.

rains commented on 2017-08-30 03:49

@khau can you show me the result of `uname -r` and `ls /usr/lib/modules/` ?
maybe you need a restart after your 'linux-headers' installed/upgraded.

khau commented on 2017-08-29 19:06

I've run into a problem (had it for some time now) compiling under the lastest kernels.

# Failing to find /lib/modules/4.12.8-2-ARCH/build/include/linux/version.h
# ...
# W115: Failed to build vmmon. Failed to execute the build command.
# ...
# W115: Failed to build vmnet. Failed to execute the build command.
# ...

Attempted with and without ams1's and orson's fixes for VMware Workstation (each tried independently and simultaneously).

Building on:
Arch Linux 4.12.8-2 (x86_64)
Using headers:
core/linux-headers 4.12.8-2

Let me know if you need any more information on how I've been attempting to build, etc.