Package Details: vlc-luajit 3.0.16-5

Git Clone URL: https://aur.archlinux.org/vlc-luajit.git (read-only, click to copy)
Package Base: vlc-luajit
Description: Multi-platform MPEG, VCD/DVD, and DivX player built with luajit for OBS Studio compatibility
Upstream URL: https://www.videolan.org/vlc/
Keywords: luajit media obs obs-studio vlc
Licenses: GPL2, LGPL2.1
Conflicts: vlc, vlc-dev, vlc-plugin, vlc-stable-git
Provides: vlc=3.0.16
Submitter: tytan652
Maintainer: tytan652
Last Packager: tytan652
Votes: 10
Popularity: 1.39
First Submitted: 2021-05-11 19:45
Last Updated: 2022-01-24 14:03

Dependencies (160)

Required by (153)

Sources (4)

Latest Comments

1 2 Next › Last »

Tio commented on 2022-01-26 12:25

Works. Thank you!

tytan652 commented on 2022-01-24 14:04

@Tio fixed in 3.0.16-5

Tio commented on 2022-01-24 13:53

I get this error when trying to update:

Building vlc-luajit...
==> Making package: vlc-luajit 3.0.16-4 (lun 24 ene 2022 14:52:08)
==> Checking runtime dependencies...
==> Checking buildtime dependencies...
==> Retrieving sources...
  -> Found vlc-3.0.16.tar.xz
  -> Found update-vlc-plugin-cache.hook
  -> Found vlc-3.0.11.1-srt_1.4.2.patch
  -> Found vlc-live-media-2021.patch
  -> Found vlc-luajit.hook
  -> Found vlc-luajit.sh
==> ERROR: Integrity checks (sha256) differ in size from the source array.
Failed to build vlc-luajit

tytan652 commented on 2021-12-13 20:02

All of them seems to be optional depedencies and are related to plugins for VLC.

It's almost the same PKGBUILD as the original vlc package, just LuaJIT and disable DeckLink (was causing issue) changes.

zeroconf commented on 2021-12-13 19:57

After updating system, rebuilding package:

yay --cleanmenu --rebuild -Syu vlc-luajit

... rebooting system, checkrebuild command claims that package vlc-luajit still needs to be rebuilt, although it is working properly. I hope this can be fixed. Below is the verbosed output of missing libraries locations.

$ checkrebuild -v

foreign vlc-luajit

ldd /usr/lib/vlc/plugins/visualization/libprojectm_plugin.so

    libprojectM.so.3 => not found

ldd /usr/lib/vlc/plugins/visualization/libgoom_plugin.so

    libgoom2.so.0 => not found

ldd /usr/lib/vlc/plugins/stream_filter/libaribcam_plugin.so

    libaribb25.so.0 => not found

ldd /usr/lib/vlc/plugins/demux/libts_plugin.so

    libaribb24.so.0 => not found

ldd /usr/lib/vlc/plugins/control/liblirc_plugin.so

    liblirc_client.so.0 => not found

ldd /usr/lib/vlc/plugins/codec/libsdl_image_plugin.so

    libSDL_image-1.2.so.0 => not found

ldd /usr/lib/vlc/plugins/codec/libkate_plugin.so

    libtiger.so.5 => not found

ldd /usr/lib/vlc/plugins/codec/libaribsub_plugin.so

    libaribb24.so.0 => not found

ldd /usr/lib/vlc/plugins/access/libnfs_plugin.so

    libnfs.so.13 => not found

tytan652 commented on 2021-06-22 08:02

@Gotchfutchian

VLC 3 only support SRT version between 1.2.2 and 1.3.0, the ArchLinux package patch this to make VLC work with SRT version beyond 1.3.0.

In your case it seems you don't get the patch applied so VLC refuse to be compiled against the actual SRT.

DON'T TRY TO DOWNGRADE SRT, it's really a bad idea, as example FFmpeg depends on the actual version and downgrading it well cause a real mess.

I repeat again it seems that your system doesn't patch in the prepare step of the package.

I already try to build it in a chroot (clean system) and no issue comes up. This is why I said it was on your side.

Remove srt and --enable-srt from the configure command if needed. But don't downgrade SRT to 1.2.2, this is not a good idea.

But note that you will be unable to open SRT stream in VLC if you do.

Gotchfutchian commented on 2021-06-21 18:52

@tytan652 Apparently mkpkg wasnt correctly resloving dependecies so i just threw it out of the build and it worked. I really only needed this for OBS-Studio-browser becasue in anything other than debian based its much harder to do -_-. If I do encounter any other issues when using ill be sure to rebuild with a manual install of srt 1.2.2 . Thanks for responding and being clear.

tytan652 commented on 2021-06-21 05:48

@Gotchfutchian, this error comes from the fact that (I don't know why) the patch about SRT is not applied in the prepare stage when you build the package.

The issue is on your side.

Because this srt >= 1.2.2 srt < 1.3.0 should be patched into srt >= 1.2.2 only.

And other things to make more recent version of SRT compatible with VLC.

Gotchfutchian commented on 2021-06-21 00:57

Error on makepkg / yay,

checking for ncursesw... yes
checking lirc/lirc_client.h usability... yes
checking lirc/lirc_client.h presence... yes
checking for lirc/lirc_client.h... yes
checking for lirc_init in -llirc_client... yes
checking for srt >= 1.2.2 srt < 1.3.0... no
configure: error: Library srt >= 1.2.2 srt < 1.3.0 needed for srt was not found
==> ERROR: A failure occurred in build().
    Aborting...

I have tried to get an older version of srt but pacman/yay wont let me for some odd reason. All help is appreciated since im a bit of a noob when it comes to arch.

Edit: removing srt seems to have allowed makepkg to work, will update when needed.

chilled commented on 2021-06-03 19:30

@tytan652

Skipping PGP signature check did it for me. Learned something new today...

Thanks a lot!