Package Details: vkquake-git 1.00.0.r9.ge4daddf-1

Git Clone URL: https://aur.archlinux.org/vkquake-git.git (read-only, click to copy)
Package Base: vkquake-git
Description: A modern Quake 1 engine. Forked from Fitzquake. This version contains Vulkan API support (git-latest).
Upstream URL: https://github.com/Novum/vkquake
Keywords: game port quake quake1 quakespasm vkquake
Licenses: GPL2
Conflicts: vkquake
Provides: vkquake
Submitter: ProfessorKaos64
Maintainer: ProfessorKaos64
Last Packager: ProfessorKaos64
Votes: 8
Popularity: 0.000001
First Submitted: 2016-08-14 02:22
Last Updated: 2018-10-01 00:49

Latest Comments

« First ‹ Previous 1 2

edoantonioco commented on 2016-09-13 05:46

~]$ vkquake-git
bash: /usr/bin/vkquake-git: Permiso denegado
~]$ sudo vkquake-git
sudo: vkquake-git: command not found

ProfessorKaos64 commented on 2016-09-12 14:20

@Vash63, ok check now please.

Vash63 commented on 2016-09-12 07:10

The PNG file in the tarball is HTML. Also the .desktop entry references /usr/games/vkquake but the PKGBUILD installs the binary to /usr/bin/vkquake-git.

ProfessorKaos64 commented on 2016-08-16 22:27

readme from upstream now included at /usr/share/doc/vkquake/readme.md

ProfessorKaos64 commented on 2016-08-14 18:14

As far as I know, nouveau drivers do not support Vulkan. You will need proprietary Nvidia/Intel (Mesa/AMDGPUpro drivers.

ProfessorKaos64 commented on 2016-08-14 16:10

The pak files must be sourced from the original game files.

ProfessorKaos64 commented on 2016-08-14 16:09

I still have some tweaks to do. You need be sure your drivers and GpU support the Vulkan API, or this will NOT work. I will include the readme from upstream in the new version. Gtx.wad indicates you do not have the id1 folder, and Pak files. They both must be lowercase. You can set the search path using the -basedir option.

esclapion commented on 2016-08-14 15:19

Where can we find those files ?

FredBezies commented on 2016-08-14 15:14

Can't run it with nouveau drivers : QUAKE ERROR: Couldn't find VK_KHR_surface/VK_KHR_xcb_surface extensions

For gfx.wad not found, well, we can see this in vkquake-git.install file :

:: You need the Quake data (.pak) files to play.
:: pak0.pak to play the shareware episode and/or
:: additionally pak1.pak for the whole game.
:: Put them into <YOUR_HOME_DIR>/.vkquake/id1/

PKGBUILD tweaks ? Both png and desktop file must be added in md5sums.

Just use makepkg -g >> PKGBUILD

esclapion commented on 2016-08-14 11:27

W_LoadWadFile: couldn't load gfx.wad