Package Details: vkcube-git r122.868ad83-2

Git Clone URL: https://aur.archlinux.org/vkcube-git.git (read-only)
Package Base: vkcube-git
Description: Demo cube app for Vulkan (git version)
Upstream URL: https://github.com/krh/vkcube
Keywords: vkcube vulkan
Licenses: MIT
Conflicts: vulkan-tools
Submitter: dvdios
Maintainer: yurikoles
Last Packager: yurikoles
Votes: 15
Popularity: 0.006591
First Submitted: 2016-02-18 22:36
Last Updated: 2019-07-27 11:28

Pinned Comments

yurikoles commented on 2019-07-27 11:29

PRs are welcome: https://github.com/yurikoles-aur/vkcube-git

Latest Comments

« First ‹ Previous 1 2 3 Next › Last »

ase1590 commented on 2017-03-31 05:15

I feel it should be added to the description that this is geared only for Intel devices to test vulkan and not nvidia or AMDGPU. it instantly crashed out on vulkan-radeon testing and it seems it doesnt work for many nvidia users either.

dvdios commented on 2016-12-30 22:06

@Smasher816
Sorry, but vkcube is developed by Intel developer so building require specifc methods found only in <vulkan/vulkan_intel.h> that is provided only by vulkan-intel.
So, until that is fixed upstream, vulkan-intel must remain only a make dependency.

Smasher816 commented on 2016-12-30 21:30

This should not depend on vulkan-intel directly (it breaks nvidia drivers). See https://wiki.archlinux.org/index.php/Vulkan#Nvidia_-_vulkan_is_not_working_and_can_not_initialize

xyproto commented on 2016-05-22 13:56

segfaults when using the nivida driver

AnAkkk commented on 2016-02-23 00:11

A dependency is missing on vulkan-headers.

dvdios commented on 2016-02-22 17:37

@intgr
Yes, vulkan-intel is nothing but the official version of old vulkan-i965-git (now unavailable)

intgr commented on 2016-02-22 15:09

vulkan-i965-git dependency is not necessary. I successfully built and ran this having installed the vulkan-intel package from extra repos: https://www.archlinux.org/packages/extra/x86_64/vulkan-intel/

dvdios commented on 2016-02-21 11:21

@IncredibleLaser
I've fixed the PKGBUILD

IncredibleLaser commented on 2016-02-21 09:07

That makes it a makedepends

dvdios commented on 2016-02-19 09:45

In build it uses vulkan_intel library, so it is required