Package Details: vivado 2021.1-3

Git Clone URL: https://aur.archlinux.org/vivado.git (read-only, click to copy)
Package Base: vivado
Description: FPGA/CPLD design suite for Xilinx devices
Upstream URL: https://www.xilinx.com/products/design-tools/vivado.html
Licenses: custom
Submitter: xiretza
Maintainer: xiretza
Last Packager: xiretza
Votes: 11
Popularity: 0.020260
First Submitted: 2019-06-18 22:23
Last Updated: 2021-07-20 08:51

Latest Comments

« First ‹ Previous 1 2 3 4 5 6 7 Next › Last »

kbeckmann commented on 2021-06-25 10:04

If anyone wants to install Vivado 2021.1 ML Standard edition and doesn't want to modify PKGBUILD, I made a small patch https://gist.github.com/kbeckmann/59fe5318900fb69a20f50081d022a42c

Focshole commented on 2021-05-24 13:14

Ok, so far I have found the required fixes to make Vitis HLS run. As first:

Create ~/.local/bin/arch with as content:

#!/bin/sh

uname -m

Then always launch vivado and vitis with LANG=en_US.UTF-8 (if it isn't your default setup) otherwise some errors may appear due to number formatting (commas instead of dots).

Finally, replace some lines in that obfuscated file as specified here: https://forums.xilinx.com/t5/Design-Entry/Vitis-HLS-2020-2-not-starting-only-splash-screen-visible/td-p/1187946

as you have written below

xiretza commented on 2021-05-01 17:11

Since the only official change with 2020.3 is support for Versal devices, I'm leaving the package at 2020.2 for now. I don't think the effort of updating and testing it is worth it, but if you think otherwise, please post a comment.

About the patch in the obfuscated tcl file, I might include that in the next update, but since it's a single-character change it might be easier for affected users to do that themselves.

leuko commented on 2021-04-17 13:10

@edmeme, I could both create a project and also open an existing one. What I noticed is that there is an unusual delay when you press open or finish.

In my case it takes about four seconds.

edmeme commented on 2021-04-17 09:28

I am having more issues with vitis, i wonder if they are isolated or a consequence of my solution. Can anyone who tried the solution create a project? My vitis gets stuck at when i press "Finish".

@leuko take it as a puzzle. Its not hard to decrypt. That line starts with ' set'

leuko commented on 2021-04-16 18:47

@edmeme I can also confirm, the solution works!!

I am just curious how you made this work working on a file which seem to be encrypted!

Here are my two cents:

sed -i "s/^\(----%r&\-'%rl%&n\$&lt'v\-\)=$/\1>/" "$pkgdir"/opt/Xilinx/Vitis_HLS/2020.2/common/scripts/autopilot_init.tcl

I did not test it in the PKGBUILD.

edmeme commented on 2021-04-16 11:35

@Golui indeed I got both versions mixed, replace the last = into a >

@Xiretza how do we get this into PKGBUILD? I think sed should work okay, the file is garbled but its valid text characters, and newlines are preserved by the 'encryption'.

Golui commented on 2021-04-16 07:37

@edmeme Seems to work, thanks a lot! Though you seem to have posted the instructions the wrong way around here. For me at least I had to change a "=" to a ">".

0xDrDru commented on 2021-04-16 06:33

That worked, thanks a lot!

edmeme commented on 2021-04-16 01:35

I just posted a solution on the xilinx forum, after a deep debug rabbit hole. Just replace in xilinx/Vitis_HLS/2020.2/common/scripts/autopilot_init.tcl line 40

----%r&-'%rl%&n$&lt'v->

with

----%r&-'%rl%&n$&lt'v-=

(Just the last character changes). Please help me verify