Package Details: visual-studio-code-wayland 1.56.2-1

Git Clone URL: https://aur.archlinux.org/visual-studio-code-wayland.git (read-only, click to copy)
Package Base: visual-studio-code-wayland
Description: The Open Source build of Visual Studio Code (vscode) editor with electron 12 beta (wayland native support)
Upstream URL: https://github.com/microsoft/vscode
Keywords: code visual-studio-code vscode wayland
Licenses: MIT
Conflicts: code
Provides: code
Submitter: jamesxu182
Maintainer: jamesxu182
Last Packager: jamesxu182
Votes: 8
Popularity: 0.32
First Submitted: 2021-01-18 23:01
Last Updated: 2021-06-08 22:09

Required by (10)

Sources (4)

Latest Comments

1 2 3 Next › Last »

lviggiani commented on 2021-05-06 19:51

According to this (https://code.visualstudio.com/updates/v1_56#_engineering) aur/visual-studio-code-bin 1.56.0-2 comes with electron 12

mattj commented on 2021-04-24 12:24

FYI, code-insiders seems to now work perfectly with code-insiders --enable-features=UseOzonePlatform --ozone-platform=wayland if anybody wants to use the official vscode vs the code-oss version.

mattj commented on 2021-04-02 17:07

Can also confirm that 12.0.0.beta.30-1 is the latest version that works for me. Although electron 12 is out I don't believe VSCode supports it yet (https://github.com/microsoft/vscode/issues/109176) and the electron-12.x.y branch.

srslizness commented on 2021-03-30 10:56

I can confirm 1.54.2-2 does not fix the issue with the latest electron13 (13.0.0.beta.4-1), it also does not work with the latest electron-beta (12.0.2-1), for me the only electron version that currently works is 12.0.0.beta.30-1. All other electron versions I have tried do not draw the window at all.

RicArch97 commented on 2021-03-26 03:26

Same issue as linos has, with the electron12-bin v12.0.2-1 VS Code launches, but the window stays empty. This new electron12 package fixed the cursor size bugs i had in Discord, so it would be nice to have this working with VS Code as well. Though when looking at this https://archlinux.org/todo/electron-12/, code might not be ready yet for the latest version of Electron 12.

linos commented on 2021-03-23 17:20

Window doesn't draw on startup with the new electron12-bin Version 12.0.1-1.

jamesxu182 commented on 2021-03-14 20:11

Hi nitsky, Thanks for your feedback. The problem was fixed in 1.54.2-2. Please update your package. The prebuilt version can be downloaded from https://github.com/Jamesxu182/visual-studio-code-wayland/blob/prebuilt/visual-studio-code-wayland-1.54.2-2-x86_64.pkg.tar.xz Thanks.

nitsky commented on 2021-03-13 16:20

With the latest update, I had to change electron-beta to electron12 in /usr/bin/code to get it to start up.

skerit commented on 2021-03-13 12:39

A dependency somewhere must have some naive version wildcard declared (or the package it depends upon thought increasing the minimum node version was just a minor change) because I'm getting this error:

error got@11.8.1: The engine "node" is incompatible with this module. Expected version ">=10.19.0". Got "10.18.1"

jamesxu182 commented on 2021-03-13 11:41

Hi mattj, Thanks for reminding me. In terms of electron-beta-bin changing from electron12 to electron13. I updated visual-studio-code-wayland to 1.54.2 with electron12-bin instead of electron-beta-bin. You can download prebuilt version from https://github.com/Jamesxu182/visual-studio-code-wayland/blob/prebuilt/visual-studio-code-wayland-1.54.2-1-x86_64.pkg.tar.xz?raw=true