Package Details: visual-paradigm 16.3-20211201

Git Clone URL: https://aur.archlinux.org/visual-paradigm.git (read-only, click to copy)
Package Base: visual-paradigm
Description: UML design application (Free 30-day trial)
Upstream URL: https://www.visual-paradigm.com/download/
Keywords: UML
Licenses: custom
Conflicts: visual-paradigm-community
Submitter: Wascar
Maintainer: przemub (ny-a)
Last Packager: ny-a
Votes: 2
Popularity: 0.000000
First Submitted: 2019-03-14 22:42
Last Updated: 2021-12-14 04:08

Latest Comments

Clansty commented on 2021-12-06 14:16

@foxite You may use archlinux-java to switch java version

foxite commented on 2021-11-10 13:21

Checksum for Visual_Paradigm_16_3_20211004_Linux64_InstallFree.tar.gz failed once again.

Also, please add a dependency on java-runtime=11, it fails to start when using JRE 17, but works fine on 11.

wiper commented on 2021-02-20 12:49

The package cannot be installed. sha256sums to Visual_Paradigm_16_2_20210101_Linux64_InstallFree.tar.gz failed

sjugge commented on 2019-11-07 11:35

Flagged as out-of-date, the upstream build version needs to be updated as well as the checksum (source).

PKGBUILD diff:

diff --git a/PKGBUILD b/PKGBUILD
index fedeed8..97331c2 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@

 pkgname=visual-paradigm
 pkgver=16.0
-pkgrel=20190869
+pkgrel=20191102
 pkgdesc="UML design application (Free 30-day trial)"
 arch=('x86_64')
 url='https://www.visual-paradigm.com/download/'
@@ -22,7 +22,7 @@ source=("https://$_server.visual-paradigm.com/visual-paradigm/vp$pkgver/$pkgrel/
   'visual-paradigm.png'
   'x-visual-paradigm.xml')

-sha256sums=('16219d4e967e168c8294426a2649572a9dfdd93f31f0c7e9079984d6ea264474'
+sha256sums=('179a29cefd163a1879514f1d4e421f2441be00c0d6db2cd7dda27dacb79ef2ed'
             'd49752a05bc69e7e5f7b23875b6ac7d7d242d761ee00030b57e9ca057babb43e'
             'fff88b05529a391dad757b380d7acf08703e11d441e04c3886e4db7f5bcd1729'
             '41517b5c2326c0ba2fe3b6647f9594f094ccf03185cf73cb87d6cf19b355ff15'

This package also seems to require java-runtime-common as this provides archlinux-java used in the install, but I didn't check that in detail.