Package Details: virtualbox-ext-oracle 5.2.0-1

Git Clone URL: https://aur.archlinux.org/virtualbox-ext-oracle.git (read-only)
Package Base: virtualbox-ext-oracle
Description: Oracle VM VirtualBox Extension Pack
Upstream URL: http://www.virtualbox.org/
Keywords: virtualbox
Licenses: custom:PUEL
Submitter: seblu
Maintainer: seblu (eworm)
Last Packager: eworm
Votes: 1170
Popularity: 12.742993
First Submitted: 2010-12-24 16:48
Last Updated: 2017-10-18 20:46

Latest Comments

Anonymous comment on 2017-10-23 23:03

Hi @seblu , you have to add version dependency of virtualbox for this package, because https://www.virtualbox.org/wiki/Downloads says: "Please install the extension pack with the same version as your installed version of VirtualBox". That is not correct to use virtualbox-ext-oracle with any version of virtualbox.

zeroflag commented on 2017-10-23 21:24

@seblu @eworm Since versioned dependencies are not used in Arch, the package maintainer, committer should've checked the versions compatibility prior committing such crippled update.

The philosophy adopted by Archlinux is KISS. But for some reason, immature community members stick to the "stupid" part only. This is not a playground, or is it...

@giogziro95 Thanks for the provided PKBUILD, mate, very much appreciated!

mxfm commented on 2017-10-23 05:03

Recent update 5.1=>5.2 has broken my virtualbox because of version mismatch.

@seblu @Scimmia this issue should be somehow fixed, or this package should have not been updated to version 5.2 without corresponding update of virtualbox from main repos.

Saying that we coudn't not do versioned dependecies because thay are broken in Arch is nonsense. If this is true, than pacman should be fixed. I am amazed how often arch people blame users and not crippled features.

By the way, this update breaks policy of not supporting partial updates, because what essentially is done is exactly partial update. I would expect that virtualbox and ext pack to be kept in syns.

giogziro95 commented on 2017-10-21 10:50

Here's a PKGBUILD for 5.1.2, if anybody's interested:

https://gist.github.com/giogziro95/da59150b7ba4731125063fa8d0b994ab

seblu commented on 2017-10-21 09:40

We do not use versioned dependencies in Arch. I remember this was suggested and tested years ago and it breaks the upgrades.

giogziro95 commented on 2017-10-21 01:18

Scimmia, in this case, it's the other way around — the VirtualBox version is lower than the Extension Pack version. And it's broken after the Extension Pack update because of the version mismatch, so it's a good idea not to update the Extension Pack only.

In order to avoid the problem you've mentioned, this can be used instead:

depends=('virtualbox>=VERSION')

Scimmia commented on 2017-10-21 01:05

scan, that doesn't really have anything to do with this package, which is just the extention pack.

giogziro95, that would make updating a massive pain in the ass for most people. You wouldn't be able to update virtualbox without uninstalling this first.

giogziro95 commented on 2017-10-21 00:44

In order to avoid the version mismatch, please add package version in the "virtualbox" dependency like this:

depends=('virtualbox=VERSION')

That way, pacman will try to update the "virtualbox" package if it's possible, or otherwise, it'll give an error.

Thanks.

scan commented on 2017-10-20 18:00

Update: The Guest Additions image with the 5.2.0 release fails to work with recent Linux guest kernels. Please try this image which we believe fixes the problem. For experimental Linux 4.14 support, please try this image. Both should work on all older guest systems too: please file a report on the bugtracker if they do not.

https://www.virtualbox.org/wiki/Downloads

amos commented on 2017-10-19 14:16

Yes, but still this should be marked as dependency
virtualbox>=5.2
so it isn't installed as long as it is incompatible.

All comments