Package Details: vim-fzf-git r327.f39c92b-1

Git Clone URL: https://aur.archlinux.org/vim-fzf-git.git (read-only)
Package Base: vim-fzf-git
Description: Vim plugin that integrates fzf, the fuzzy file finder
Upstream URL: https://github.com/junegunn/fzf.vim
Licenses: MIT
Submitter: mherzberg
Maintainer: mherzberg
Last Packager: mherzberg
Votes: 0
Popularity: 0.000000
First Submitted: 2018-08-21 12:00
Last Updated: 2018-08-21 12:00

Latest Comments

ixil commented on 2019-09-12 04:07

@mherzberg , apologies, I missed the extra ./fzf/ directory. I'm not sure what conflict I had in January (or if there even were one) and the latest one was merely because I was trying to test a bugfix from fzf-git - which as you rightly point out is erroneous, in not following the community fzf package (I have commented on that package - since it breaks the package as working alternative dependency). IMO upstream should probably have made the naming of the fzf.vim files a little clearer. Anyway, again, sorry for the noise.

mherzberg commented on 2019-09-10 11:41

@ixil again, what error do you get, exactly? This package, vim-fzf-git, installs the fzf.vim file into /usr/share/vim/vimfiles/plugin/fzf/fzf.vim, which is a different location than the fzf package, so I do not see how you get a conflict. If the fzf-git package does something differently than fzf, then that seems to be an issue with fzf-git to me.

ixil commented on 2019-09-09 17:09

Unfortunately the junegunn/fzf repository has a file named plugin/fzf.vim, and junegunn/fzf-vim also has plugin/fzf.vim that depends on junegunn/fzf. They are different files with different functions but the same name. The fzf-git aur package does not install the required fzf.vim

The fzf package are in conflict as they both try to install to usr/share/vim/vimfiles/plugin/fzf

I changed the install script to install the file to usr/share/vim/vimfiles/plugin/fzf/fzf-funcs.vim

mherzberg commented on 2019-01-21 15:09

@ixil what error do you get?

ixil commented on 2019-01-19 16:37

This has a file conflict with community/fzf. The file /usr/share/vim/vimfiles/plugins/fzf.vim in the fzf package is a dependency of the same file in this package.