Package Details: viber 12.0.0.7-1

Git Clone URL: https://aur.archlinux.org/viber.git (read-only, click to copy)
Package Base: viber
Description: Proprietary cross-platform IM and VoIP software
Upstream URL: https://www.viber.com
Licenses: custom
Submitter: MohammadR
Maintainer: nslxndr
Last Packager: nslxndr
Votes: 247
Popularity: 3.51
First Submitted: 2013-08-20 17:20
Last Updated: 2019-12-07 13:50

Latest Comments

1 2 3 4 5 6 ... Next › Last »

vblats commented on 2020-08-10 18:12

Could please someone change sha256 to 1037a48d74caef33d123b166da2bfb1fe8fa67590b8669ecf25b314f41374267 ?

Thanks!

damir commented on 2020-08-08 22:18

needed this pkg to work so old relatives can simply have it working in linux, so i updated it and addapted dependencies avoiding missing qt5 libs:

pkgver=13.3.1
depends=('libxss' 'xcb-util-image' 'xcb-util-keysyms' 'xcb-util-renderutil'  'xcb-util-wm' 'libxss' 'nss' 'libxcomposite' 'gst-plugins-base' 'gst-plugins-good' 'gst-plugins-ugly' 'gst-libav' 'libxslt' 'openssl-1.0' 'icu55' 'qrencode' 'libpng12' 'qt5-webengine' 'qt5-3d' 'qt5-remoteobjects' 'qt5-multimedia' 'qt5-websockets' 'qt5-virtualkeyboard')
md5sums=('d85f509804d5b83d602eafe5dc22dead')

noobfromby commented on 2020-07-23 14:47

Congratulation! Calls work in new version! Change a SHA in PKGBUILD and then install.

kaynetik commented on 2020-07-20 06:40

@Sirius, a new version came out, thus SHA of the package changed.

Currently it's: 1037a48d74caef33d123b166da2bfb1fe8fa67590b8669ecf25b314f41374267

So, until the maintainer verifies and alters the build, your temporary workaround would be to edit the PKGBUILD SHA on line 19.

Sirius commented on 2020-07-18 21:05

I got this error when I tried to install viber: ==> Making package: viber 12.0.0.7-1 (Sat Jul 18 23:22:27 2020) ... ==> Validating source files with sha256sums... viber-12.0.0.7.deb ... FAILED ==> ERROR: One or more files did not pass the validity check!

Rverkvn commented on 2020-07-04 13:13

At the first start, the program displayed an error:

"qt.qpa.plugin: Could not load the Qt platform plugin" xcb "in" "even though it was found. This application failed to start because no Qt platform plugin could be initialized. Reinstalling the application may fix this problem. "

After installing the qt5-base package, everything worked. You need to add this package depending.

rapurapu commented on 2020-06-14 08:39

@everyone

Call is working in the snap version but version is outdated

noobfromby commented on 2020-06-14 08:35

Calls don' t work. Does anybody solve this problem?

Mel commented on 2020-05-29 12:48

[1:14:0529/143436.591733:ERROR:adm_helpers.cc(73)] Failed to query stereo recording.
../../3rdparty/chromium/sandbox/linux/seccomp-bpf-helpers/sigsys_handlers.cc:**CRASHING**:seccomp-bpf failure in syscall 0230

syscall 0230: "Assuming 0230 is decimal, this corresponds to clock_nanosleep. Presumably, the existing seccomp filters in chromium only allow nanosleep, but not clock_nanosleep. They need to be adjusted."[1]

Bug report in [1] also states "There are fixes upstream at Qt based on the Chromium fixes" so unless they do a rebuild, I'm thinking I'll uninstall Viber instead of "enjoying it on their other platforms".

firewalker commented on 2020-05-28 11:48

I opened a ticket for the issue with glibc. The response:

We have decided to put any updates for Linux on hold until further notice. There are no version releases planned in the foreseeable future. I apologize for any inconvenience. We hope that you can still enjoy Viber on our other platforms!