Package Details: viagee 3.0-2

Git Clone URL: https://aur.archlinux.org/viagee.git (read-only, click to copy)
Package Base: viagee
Description: Formerly gnome-gmail. It allows desktop mail actions, such as 'Send File as Email' or web 'mailto' links, to be handled by the Gmail web client.
Upstream URL: https://davesteele.github.io/viagee/
Licenses: GPL2
Conflicts: gnome-gmail
Provides: gnome-gmail
Replaces: gnome-gmail
Submitter: ainola
Maintainer: max.bra
Last Packager: max.bra
Votes: 63
Popularity: 1.71
First Submitted: 2021-04-24 00:13
Last Updated: 2021-05-18 06:43

Latest Comments

« First ‹ Previous 1 2 3 4 5 Next › Last »

j1simon commented on 2016-08-03 17:07

$ cat /etc/locale.conf
LANG=es_ES.UTF-8
LC_COLLATE=C

Every link I try to open fails, for example: gnome-gmail mailto:alexis.jaksone+ifastestgmail@gmail.com

It only fails when I execute it from console.

max.bra commented on 2016-08-03 08:04

your /etc/locale.conf?

can you post the link that generate your error?

j1simon commented on 2016-08-02 11:03

@max.bra https://github.com/davesteele/gnome-gmail/issues/29

$ grep "^[^#]" /etc/locale.gen
es_ES.UTF-8 UTF-8
en_US.UTF-8 UTF-8
en_US ISO-8859-1
es_ES ISO-8859-1
es_ES@euro ISO-8859-15

max.bra commented on 2016-08-01 21:18

hi j1simon,
gnome-gmail has been recently and officialy ported to python 3, and it's working here.

can you please copy-paste result of this:
grep "^[^#]" /etc/locale.gen

j1simon commented on 2016-08-01 16:15

It fails with python3:

$ gnome-gmail mailto:alexis.jaksone+ifastestgmail@gmail.com
Traceback (most recent call last):
File "/usr/share/gnome-gmail/gnomegmail.py", line 852, in <module>
main()
File "/usr/share/gnome-gmail/gnomegmail.py", line 837, in main
gmailurl = gm_url.gmail_url()
File "/usr/share/gnome-gmail/gnomegmail.py", line 563, in gmail_url
gmailurl = self.api_gmail_url()
File "/usr/share/gnome-gmail/gnomegmail.py", line 530, in api_gmail_url
gm_api.form_message()
File "/usr/share/gnome-gmail/gnomegmail.py", line 341, in form_message
self.message_text = msg.as_bytes()
File "/usr/lib/python3.5/email/message.py", line 179, in as_bytes
g.flatten(self, unixfrom=unixfrom)
File "/usr/lib/python3.5/email/generator.py", line 115, in flatten
self._write(msg)
File "/usr/lib/python3.5/email/generator.py", line 181, in _write
self._dispatch(msg)
File "/usr/lib/python3.5/email/generator.py", line 214, in _dispatch
meth(msg)
File "/usr/lib/python3.5/email/generator.py", line 288, in _handle_multipart
self._write_lines(preamble)
File "/usr/lib/python3.5/email/generator.py", line 161, in _write_lines
self.write(laststripped)
File "/usr/lib/python3.5/email/generator.py", line 410, in write
self._fp.write(s.encode('ascii', 'surrogateescape'))
UnicodeEncodeError: 'ascii' codec can't encode character '\xed' in position 18: ordinal not in range(128)

If I change the launcher to: python2 /usr/share/gnome-gmail/gnomegmail.py "$@"
it works well.

max.bra commented on 2012-02-14 19:19

done. thanks for advice.

Anonymous comment on 2012-02-14 17:25

gnome-python-desktop brings in a lot of unnecessary dependencies. Installing python2-gconf, python2-gobject2, python-gnomekeyring and dbus-python are sufficient.

max.bra commented on 2011-12-28 18:51

gnome-python bindings are still at 2.32.x version.
really no problem, install it safely

cbowman57 commented on 2011-12-28 16:12

I'm a little hesitant to try this, it seems to want to install a lot of gnome 2.32 dependencies.

Is this ok to run as-is on Gnome 3?

max.bra commented on 2011-11-21 09:37

where and when do you get that error?