Package Details: veusz 3.3.1-2

Git Clone URL: https://aur.archlinux.org/veusz.git (read-only, click to copy)
Package Base: veusz
Description: A 2D and 3D scientific plotting package, designed to create publication-ready PDF or SVG output
Upstream URL: https://veusz.github.io/
Licenses: GPL2
Submitter: None
Maintainer: sirocco
Last Packager: sirocco
Votes: 47
Popularity: 0.027826
First Submitted: 2008-10-03 15:23
Last Updated: 2021-01-13 12:59

Dependencies (10)

Required by (0)

Sources (1)

Latest Comments

1 2 3 Next › Last »

danberdev commented on 2021-01-12 18:47

Veusz depends on sip that has received a major update, apparently breaking it into several smaller tools. The package in the [extra] repository provides the new version, thus build fails.

To fix that manually install sip4. It'll provide the needed /usr/bin/sip for successful installation.

Vitrum-cnkj34kr8 commented on 2020-12-08 17:11

My problem was in this line:

  ln -s /usr/lib/python3.9/site-packages/PyQt5/bindings/ NEW/PyQt5

Manjaro is still using Python 3.8; after fixing, it compiles correct.

Vitrum-cnkj34kr8 commented on 2020-12-08 16:20

Recents update v3.3.1-1 fails on build():

building 'veusz.helpers.threed' extension
/usr/bin/sip -c build/temp.linux-x86_64-3.8/sip-threed -n PyQt5.sip -t Qt_5_15_0 -t WS_X11 -I NEW/PyQt5 veusz/helpers/src/threed/threed.sip
sip: Unable to find file "QtCore/QtCoremod.sip"
error: command '/usr/bin/sip' failed with exit status 1
==> ERROR: A failure occurred in build().

bruno.unna commented on 2020-03-09 18:48

I haven't used this application in a while, and now that I need it I get this when trying to run it from the command line:

singularity :: ~ % veusz                                                                                 
Traceback (most recent call last):
  File "/usr/bin/veusz", line 6, in <module>
    from pkg_resources import load_entry_point
  File "/usr/lib/python3.8/site-packages/pkg_resources/__init__.py", line 3254, in <module>
    def _initialize_master_working_set():
  File "/usr/lib/python3.8/site-packages/pkg_resources/__init__.py", line 3237, in _call_aside
    f(*args, **kwargs)
  File "/usr/lib/python3.8/site-packages/pkg_resources/__init__.py", line 3266, in _initialize_master_working_set
    working_set = WorkingSet._build_master()
  File "/usr/lib/python3.8/site-packages/pkg_resources/__init__.py", line 584, in _build_master
    ws.require(__requires__)
  File "/usr/lib/python3.8/site-packages/pkg_resources/__init__.py", line 901, in require
    needed = self.resolve(parse_requirements(requirements))
  File "/usr/lib/python3.8/site-packages/pkg_resources/__init__.py", line 787, in resolve
    raise DistributionNotFound(req, requirers)
pkg_resources.DistributionNotFound: The 'veusz==3.1' distribution was not found and is required by the application

Any help greatly appreciated.

trb commented on 2018-07-14 15:55

I couldn't build a package without a "sip" package from the official repo, maybe it should be added as the dependency ?

giniu commented on 2018-04-14 21:45

I no longer use this package. If anyone wants to pick maintenance, go on and have fun.

sirocco commented on 2018-04-10 05:34

https://pastebin.com/uVpRv1Wj

Veusz 2.2.2; python 3 and Qt5

mizuchi commented on 2017-09-28 16:07

Just replace 1.26.1 with number of the current version and update hash sum. The resulting package works well.

sirocco commented on 2017-09-17 11:05

Veusz 2.0

Veusz has been updated to use Qt5 and PyQt5.

unlucu commented on 2017-07-20 07:31

Just for acknowledgement, if you exchange "python2" with "python" veusz runs using python3 instead of python2.