Package Details: vdhcoapp 1.3.0-1

Git Clone URL: https://aur.archlinux.org/vdhcoapp.git (read-only)
Package Base: vdhcoapp
Description: Companion application for Video DownloadHelper browser add-on
Upstream URL: https://github.com/mi-g/vdhcoapp
Licenses: GPL2
Submitter: dguihal
Maintainer: dguihal (rodrigo21)
Last Packager: rodrigo21
Votes: 46
Popularity: 3.533045
First Submitted: 2017-11-16 23:54
Last Updated: 2019-06-25 21:51

Latest Comments

« First ‹ Previous 1 2

Styx85 commented on 2018-01-22 12:07

[FIXED]: Fixed with version vdhcoapp 1.1.2-2

I'm lately getting some build error:

[12:58:35] Using gulpfile /tmp/yaourt-tmp-chanyeoncho/aur-vdhcoapp/src/vdhcoapp-1.1.2/gulpfile.js [12:58:35] Starting 'default'... [12:58:35] Starting 'build-local'...

pkg@4.3.0 Error! No available node version satisfies 'node7' [12:58:35] 'build-local' errored after 47 ms

Sounds like a build dependency problem to me, but I couldn't figure out what package is missing so far.

duht commented on 2018-01-22 11:26

[12:19:58] Using gulpfile /tmp/makepkg/vdhcoapp/src/vdhcoapp-1.1.2/gulpfile.js [12:19:58] Starting 'build-linux-64'...

pkg@4.3.0 Error! No available node version satisfies 'node7' [12:19:58] 'build-linux-64' errored after 43 ms [12:19:58] Error: No available node version satisfies 'node7'

AJSlye commented on 2017-12-03 23:05

If your sure it works, I'll take your word for it. ;) Personally, I prefer consistency.

rodrigo21 commented on 2017-12-02 16:35

Hi AJSlye, is not necessary to change the patch. I changed the way the patch is applied, now it discards the reference to 1.0.7.

You can test if it's working by trying to download and convert a YouTube video.

AJSlye commented on 2017-12-02 13:57

I made the necessary changes to my files here:
https://github.com/NuLogicSystems/PKGBUILD/blob/master/vdhcoapp/PKGBUILD
https://github.com/NuLogicSystems/PKGBUILD/blob/master/vdhcoapp/vdhcoapp.patch

Changes: https://github.com/NuLogicSystems/PKGBUILD/commit/d316b04d2ddc8d5252dd24dc13ce53f9ba4dca1a

AJSlye commented on 2017-12-02 13:21

Shouldn't you have updated the contents of the patch as well?
Inside the patch still references 1.0.7:
diff -ura package.orig/vdhcoapp-1.0.7/app/converter.js package.new/vdhcoapp-1.0.7/app/converter.js
diff -ura package.orig/vdhcoapp-1.0.7/app/native-autoinstall.js package.new/vdhcoapp-1.0.7/app/native-autoinstall.js

Wouldn't this actually cause the patch to not be applied?

rodrigo21 commented on 2017-11-17 14:38

Hi, Thanks for adding me as co-maintainer.

I've updated the package. Now it's building from source and I also changed the executable name to only /usr/bin/vdhcoapp.
The ffmpeg dependency is to convert the videos directly.

Please test it. If you can build for i686 please do as I can't at the moment.

dguihal commented on 2017-11-17 09:49

Hi rodrigo, I've added you as a co-maintainer

rodrigo21 commented on 2017-11-17 03:19

Hi, this package is not working here.
If you look at the extension settings in Firefox, it'll say that's verifying, but it doesn't work.

I spent a lot of time trying to make it work without the bundled ffmpeg.
You have to patch 2 files and build from source.

If you want, you can put me as co-maintainer and I'll update the package.