Package Details: vdfuse 82a-12

Git Clone URL: https://aur.archlinux.org/vdfuse.git (read-only, click to copy)
Package Base: vdfuse
Description: A FUSE module for mounting VirtualBox disk images (VDI/VMDK/VHD) on the host
Upstream URL: http://forums.virtualbox.org/viewtopic.php?f=26&t=33355
Licenses: GPL3
Submitter: tdy
Maintainer: Muflone
Last Packager: Muflone
Votes: 135
Popularity: 0.000241
First Submitted: 2009-10-15 04:51
Last Updated: 2020-02-08 21:54

Latest Comments

« First ‹ Previous 1 2 3 4 5 Next › Last »

someoneelse123 commented on 2013-03-23 12:23

virtualbox-sdk package is needed by vdautomount script.

teekay commented on 2012-09-24 10:14

@laloch: See http://lists.alioth.debian.org/pipermail/pkg-virtualbox-devel/2012-March/003572.html - don't use his xspect3d/gordstuff/vdfuse-v82a.tgz, use the debian one instead.

teekay commented on 2012-09-14 21:28

I needed this, so here's the update.

* Use debian maintained version - it's the sane one
* Compile using upstream headers matching debian's version

I didn't test vdautomount.

Anonymous comment on 2012-03-19 03:28

makepkg breaks with the following errors:

==> Starting build()...
vdfuse-v82a.c: In function ‘detectDiskType’:
vdfuse-v82a.c:518:7: warning: ignoring return value of ‘read’, declared with attribute warn_unused_result [-Wunused-result]
/usr/bin/ld: /tmp/cc0pWkfJ.o: undefined reference to symbol 'VDWrite'
/usr/bin/ld: note: 'VDWrite' is defined in DSO /usr/lib/virtualbox/VBoxDDU.so so try adding it to the linker command line
/usr/lib/virtualbox/VBoxDDU.so: could not read symbols: Invalid operation
collect2: ld returned 1 exit status
strip: 'vdfuse-v82a': No such file
Compile Failed!
==> Starting package()...
install: cannot stat `vdfuse-v82a': No such file or directory
==> ERROR: A failure occurred in package().

Shanto commented on 2011-12-07 09:45

vdautomount no longer works with current VirtualBox.

Shanto commented on 2011-11-07 15:14

@tdy: I think virtualbox-sdk should be added to depends, for the vbox Python modules utilized by this program.

jackoneill commented on 2011-07-17 13:06

Uhh, sorry, the previous message is not targeted specifically at the maintainer of this package, but at everyone (ambiguous "you" ftl).

jackoneill commented on 2011-07-17 12:58

Ohai there.

The owner of http://downloads.sourceforge.net/project/xspect3d/gordstuff/vdfuse-v82a.tgz would appreciate it if you stopped sending him bugreports and expecting fixes — apparently he just fixed someone else's code at one time. Anyway, you're more than welcome to fork this (hint hint). The tarball may or may not remain available.

(He doesn't have an account here, so I'm relaying the message instead.)

tdy commented on 2011-04-01 16:40

thanks, 'force' was deprecated for 'epoch' in pacman 3.5

dhaines commented on 2011-03-31 11:35

The PKGBUILD is causing makepkg to throw an error: "options array contains unknown option 'force'". Also, I see that the md5 that I mentioned was added, but that pkgrel was not incremented. Shouldn't that be the case?