Package Details: vcsi 7-2

Git Clone URL: https://aur.archlinux.org/vcsi.git (read-only)
Package Base: vcsi
Description: Create video contact sheets, thumbnails
Upstream URL: https://github.com/amietn/vcsi
Licenses: MIT
Submitter: spiridow
Maintainer: spiridow
Last Packager: spiridow
Votes: 7
Popularity: 0.109545
First Submitted: 2015-05-02 15:26
Last Updated: 2018-12-30 07:52

Latest Comments

Rus commented on 2019-11-13 21:22

This version breaks about wmv, there is no such problem with the git version https://aur.archlinux.org/packages/vcsi-git/

Traceback (most recent call last): File "/usr/bin/vcsi", line 11, in <module> load_entry_point('vcsi==7', 'console_scripts', 'vcsi')() File "/usr/lib/python3.7/site-packages/vcsi/init.py", line 3, in main vcsi.vcsi.main() File "/usr/lib/python3.7/site-packages/vcsi/vcsi.py", line 1331, in main process_file(filename, args) File "/usr/lib/python3.7/site-packages/vcsi/vcsi.py", line 1343, in process_file verbose=args.is_verbose) File "/usr/lib/python3.7/site-packages/vcsi/vcsi.py", line 93, in init self.compute_display_resolution() File "/usr/lib/python3.7/site-packages/vcsi/vcsi.py", line 157, in compute_display_resolution sample_aspect_ratio = self.video_stream["sample_aspect_ratio"] KeyError: 'sample_aspect_ratio'

tmoorman commented on 2017-01-10 19:07

If you have python 3.6 installed then you need to rebuild the package and reinstall. Otherwise, vcsi looks in /usr/lib/python3.6/site-packages for its files and can't find them since they are in /usr/lib/python3.5/site-packages. Rebuilding the package puts them in 3.6