Package Details: vcmi 0.99-4

Git Clone URL: https://aur.archlinux.org/vcmi.git (read-only, click to copy)
Package Base: vcmi
Description: Open-source engine for Heroes of Might and Magic III
Upstream URL: http://vcmi.eu
Keywords: homm3
Licenses: GPL2
Conflicts: fuzzylite
Submitter: Raziel23
Maintainer: bwrsandman
Last Packager: bwrsandman
Votes: 33
Popularity: 0.000711
First Submitted: 2013-03-12 14:11
Last Updated: 2018-02-20 04:06

Pinned Comments

jstamant commented on 2017-10-22 22:28

WARNING!
There's a bug where your home directory will be wiped if you uninstall any mods using the vcmi launcher.
It has been fixed in the development branch, but is still present in v0.99.
Yes: I lost all my personal files. Luckily I have daily backups.
https://bugs.vcmi.eu/view.php?id=2673

Latest Comments

« First ‹ Previous 1 2 3 4

Raziel23 commented on 2014-06-16 19:39

@Tjuh: I have to admit that I've also experienced this situation, even with my 8 GB of memory.
I can successfully compiled the vcmi but like you said its freezing the system during compilation.
I can't do anything with this. This issue not occur with the vcmi-git package so you should use it.
In the future in the vcmi version 0.96 this issue should not exist.

Tjuh commented on 2014-06-16 13:10

I am not able to compile this, I can't get past 3% due to it freezing up my system. I have 4GB of mem, yet it keeps draining them and crashing.

Raziel23 commented on 2014-05-11 07:17

@salviati: I'm aware that there is already the development version of vcmi (0.95b), but this version
is mainly intended for testers and it isn't considered as the stable version. This package however
contain the stable version.

If you want follow more closely the project you can use vcmi-git which is in fact the development
version of vcmi (precisely speaking vcmi 0.95b was announced in git commit 1dbc0c7).

Raziel23 commented on 2014-03-02 12:58

[Bump to version 0.95-1]. New upstream release. The changelog is as follows:
http://forum.vcmi.eu/viewtopic.php?p=11664#11664

I've also removed -DENABLE_LAUNCHER='Yes' option. Now it's enabled by default.

Raziel23 commented on 2013-12-27 14:43

@Arhat: Vcmi has many configuration files written in json data format. You can list with command:
pacman -Ql vcmi |grep json

The best way to change theme is to copy appropriate configuration files to corresponding directories
within ~/.vcmi directory and there modify them (in this manner the original configuration files remain
intact and your modified configuration files will not be overwritten when you install new version of vcmi
in the future).

So to answer your question, simply copy defaultMods.json file to ~/.vcmi/config directory with command:
cp /usr/share/vcmi/config/defaultMods.json ~/.vcmi/config/
Edit it and change "STACK_EXPERIENCE" and "COMMANDERS" options from false to true value.

BTW. This question should be directed to the vcmi forum :)

Arhat commented on 2013-12-27 10:22

Thanks for your work here.

Following the discussions in the vcmi forum, I gathered, that two WoG features should work with vcmi: commanders and stack experience.

However I can't get either of them to work.

I do have the Mods/WoG/Data/zvs Directory and the mod.json file.

vmcilauncher says WoG is installed.

Any ideas what else I need to look for?

Raziel23 commented on 2013-10-02 11:37

[Bump to version 0.94-1]. New upstream release. The changelog is as follows:
http://forum.vcmi.eu/viewtopic.php?p=10538#10538

I've also added qt5-base dependency in order to compile and run properly vcmilauncher (mod manager).
vcmilauncher can automatically download and manage available mods for vcmi.

Raziel23 commented on 2013-06-01 20:48

[Bump to version 0.93-1]. New upstream release. The changelog is as follows:
http://forum.vcmi.eu/viewtopic.php?p=9354

Raziel23 commented on 2013-05-09 07:42

[Bump to version 0.92-2]. I have take advantage of pacman version 4.1 and slightly update
the PKGBUILD. The changes I have made are:
- removed from makedepends subversion (it shouldn't be there)
- added a prepare() function which creates an empty build directory
- added three new dependencies (desktop-file-utils, gtk-update-icon-cache, hicolor-icon-theme)
in order to update icon and desktop files after installing, updating and removing
the vcmi package
- removed two dependencies (sdl, zlib) because they are already satisfied by other packages
(respectively by boost-libs and sdl_image)
- added a post remove message which tells that in order to completely remove the vcmi
package you have to manually remove the ~/.vcmi directory

If you encounter any problems with new PKGBUILD please leave here a comment.