Package Details: vcmi 0.99-4

Git Clone URL: https://aur.archlinux.org/vcmi.git (read-only)
Package Base: vcmi
Description: Open-source engine for Heroes of Might and Magic III
Upstream URL: http://vcmi.eu
Keywords: homm3
Licenses: GPL2
Conflicts: fuzzylite
Submitter: Raziel23
Maintainer: bwrsandman
Last Packager: bwrsandman
Votes: 34
Popularity: 0.102914
First Submitted: 2013-03-12 14:11
Last Updated: 2018-02-20 04:06

Pinned Comments

jstamant commented on 2017-10-22 22:28

WARNING!
There's a bug where your home directory will be wiped if you uninstall any mods using the vcmi launcher.
It has been fixed in the development branch, but is still present in v0.99.
Yes: I lost all my personal files. Luckily I have daily backups.
https://bugs.vcmi.eu/view.php?id=2673

Latest Comments

1 2 3 4 Next › Last »

Linuxman commented on 2018-09-28 06:04

Hi! It is don't wanna rebuild with 1.68 version of boost library

[code] In file included from /usr/include/boost/range/algorithm/max_element.hpp:12, from /usr/include/boost/range/algorithm.hpp:97, from /home/user/.cache/yay/vcmi/src/vcmi-0.99/AI/VCAI/../../Global.h:178, from /home/user/.cache/yay/vcmi/src/vcmi-0.99/AI/VCAI/StdInc.h:2, from /home/user/.cache/yay/vcmi/src/vcmi-0.99/AI/VCAI/cotire/VCAI_CXX_prefix.cxx:4, from /home/user/.cache/yay/vcmi/src/vcmi-0.99/AI/VCAI/cotire/VCAI_CXX_prefix.hxx:4: /usr/include/boost/algorithm/minmax_element.hpp: In instantiation of ‘bool boost::detail::binary_pred_over_iter<iterator, binarypredicate="">::operator()(const Iterator&, const Iterator&) const [with Iterator = gnu_cxx::normal_iterator<const cgdwelling*="" cgdwelling**,="" std::vector<const=""> >; BinaryPredicate = CDistanceSorter]’: /usr/include/boost/algorithm/minmax_element.hpp:218:15: required from ‘ForwardIter boost::detail::basic_first_min_element(ForwardIter, ForwardIter, BinaryPredicate) [with ForwardIter = gnu_cxx::normal_iterator<const cgdwelling*="" cgdwelling**,="" std::vector<const=""> >; BinaryPredicate = boost::detail::binary_pred_over_iter<gnu_cxx::normal_iterator<const cgdwelling*="" cgdwelling**,="" std::vector<const=""> >, CDistanceSorter>]’ /usr/include/boost/algorithm/minmax_element.hpp:276:43: required from ‘ForwardIter boost::first_min_element(ForwardIter, ForwardIter, BinaryPredicate) [with ForwardIter = gnu_cxx::normal_iterator<const cgdwelling*="" cgdwelling**,="" std::vector<const=""> >; BinaryPredicate = CDistanceSorter]’ /usr/include/boost/range/algorithm/min_element.hpp:53:36: required from ‘typename boost::range_iterator<c>::type boost::range::min_element(ForwardRange&, BinaryPredicate) [with ForwardRange = std::vector<const cgdwelling*="">; BinaryPredicate = CDistanceSorter; typename boost::range_iterator<c>::type = gnu_cxx::normal_iterator<const cgdwelling*="" cgdwelling**,="" std::vector<const=""> >]’ /home/user/.cache/yay/vcmi/src/vcmi-0.99/AI/VCAI/Goals.cpp:927:88: required from here /usr/include/boost/algorithm/minmax_element.hpp:47:73: error: no match for call to ‘(const CDistanceSorter) (const CGDwelling&, const CGDwelling&)’ Iterator const& it2) const { return m_p(it1, it2); } ^ In file included from /home/user/.cache/yay/vcmi/src/vcmi-0.99/AI/VCAI/Goals.h:7, from /home/user/.cache/yay/vcmi/src/vcmi-0.99/AI/VCAI/Goals.cpp:2: /home/user/.cache/yay/vcmi/src/vcmi-0.99/AI/VCAI/AIUtility.h:170:7: note: candidate: ‘bool CDistanceSorter::operator()(const CGObjectInstance, const CGObjectInstance)’ <near match=""> bool operator ()(const CGObjectInstance lhs, const CGObjectInstance rhs); ^~~~~~~~ /home/user/.cache/yay/vcmi/src/vcmi-0.99/AI/VCAI/AIUtility.h:170:7: note: passing ‘const CDistanceSorter’ as ‘this’ argument discards qualifiers /home/user/.cache/yay/vcmi/src/vcmi-0.99/AI/VCAI/Goals.cpp: In member function ‘std::__cxx11::string Goals::AbstractGoal::name() const’: /home/user/.cache/yay/vcmi/src/vcmi-0.99/AI/VCAI/Goals.cpp:69:45: warning: this statement may fall through [-Wimplicit-fallthrough=] desc = "GET OBJ " + obj->getObjectName(); ^ /home/user/.cache/yay/vcmi/src/vcmi-0.99/AI/VCAI/Goals.cpp:71:3: note: here case FIND_OBJ: ^~~~ make[2]: [AI/VCAI/CMakeFiles/VCAI.dir/build.make:105: AI/VCAI/CMakeFiles/VCAI.dir/Goals.cpp.o] Error 1 make[1]: [CMakeFiles/Makefile2:877: AI/VCAI/CMakeFiles/VCAI.dir/all] Error 2 make: ** [Makefile:152: all] Error 2 [/code]</near></const></c></const></c></const></const></const></const></iterator,>

axfelix commented on 2018-05-07 05:01

Anyone feel like making a precompiled binary package? For a recreation of a game engine from 1999 this takes a surprisingly long time to build (it filled up my 2GB /tmp and I haven't felt like trying again yet)...

yktor commented on 2018-02-15 22:45

Patch to prevent $HOME deletion: https://hastebin.com/obozorezox.cpp

Patch to fix compilation with new boost: https://hastebin.com/womijexiyi.cpp

Please update PKGBUILD

jstamant commented on 2017-10-22 22:28

WARNING!
There's a bug where your home directory will be wiped if you uninstall any mods using the vcmi launcher.
It has been fixed in the development branch, but is still present in v0.99.
Yes: I lost all my personal files. Luckily I have daily backups.
https://bugs.vcmi.eu/view.php?id=2673

MarcinWieczorek commented on 2017-10-17 17:08

Hello, please rename the tarball to $pkgname-$pkgver like format, so it is possible to use shared source directory. Thank you.

argarak commented on 2016-10-23 22:51

@gonciarz I've documented the problem on your VCMI issues page (http://bugs.vcmi.eu/view.php?id=2511) so see the most recent note for more details.

And @bwrsandman, please remove the `minizip` dependency (also in vcmi-git), as currently, one has to remove it to get any mods to install.

gonciarz commented on 2016-10-04 22:18

I retested the newest vcmi package. I'm able to compile it but when I try to install WOG from vcmilauncher I got Segmentation fault:

vcmilauncher
Failed to open file /home/ruppertus/.config/vcmi/modSettings.json
File <unknown> is not a valid JSON file!
At line 21, position 2 warning: Comma expected!
At line 36, position 1 warning: Comma expected!

File <unknown> is not a valid JSON file!
At line 21, position 2 warning: Comma expected!
At line 36, position 1 warning: Comma expected!

Segmentation fault (core dumped)

gonciarz commented on 2016-10-03 22:32

I'm sorry for a mess. I've checked vcmi-git package. I'll retest it against vcmi soon.

bwrsandman commented on 2016-10-03 15:23

There seems to be a bug in builder, it doesn't exist in the vcmi-git package.

When I have the time, I will try and find the patch which fixes it.

For the meantime, you can try installing the vcmi-git package, running vcmibuilder, then installing the vcmi package.

gonciarz commented on 2016-10-03 15:19

Thanks, anyway I'm not able to install anything from vcmilauncher. Example scenario:
1. rm -rf ~/.local/share/vcmi ~/.cache/vcmi ~/.config/vcmi ~/.local/share/vcmi/Saves
2. vcmibuilder --data ~/heroes3_complete_installation
3. vcmilauncher
4. From Launcher, install WOG
causes crash.
If you are able to recreate it on your arch, then please add the proper comment in http://bugs.vcmi.eu/view.php?id=2511 otherwise please let me know if I'm doing something wrong.