Package Details: vala-panel-appmenu-xfce-git 0.7.4-1

Git Clone URL: https://aur.archlinux.org/vala-panel-appmenu-xfce-git.git (read-only, click to copy)
Package Base: vala-panel-appmenu-xfce-git
Description: AppMenu (Global Menu) plugin for xfce4-panel
Upstream URL: https://gitlab.com/vala-panel-project/vala-panel-appmenu
Licenses: LGPL3
Submitter: rilian
Maintainer: rilian
Last Packager: rilian
Votes: 34
Popularity: 0.014330
First Submitted: 2015-04-01 21:00
Last Updated: 2020-09-07 21:03

Dependencies (23)

Required by (1)

Sources (1)

Latest Comments

1 2 3 4 5 6 ... Next › Last »

rilian commented on 2020-09-21 14:46

@NovaViper

Because it is build dependency and you should build a package for ALL DEs at once (not just for XFCE).

NovaViper commented on 2020-09-21 14:17

Why is bungie a dependency when the package is meant for XFCE? I keep getting dependency for the bungie package when Im using XFCE

jextrevor commented on 2020-09-08 18:04

Interesting, so I'm looking at the page for budgie, and gobject-introspection is listed as a make dependency. Perhaps we need to just add it here as a make dependency as well... because this isn't building budgie, it's just using it as a dependency. Not sure

rilian commented on 2020-09-08 17:54

In budgie, I think.

jextrevor commented on 2020-09-08 17:18

Doing yay -S gobject-introspection and then installing again fixed it for me as well. I'm not sure about the missing dependency... is that something that's truly missing here/in vala-panel-appmenu-common-git or is it missing in budgie-desktop?

andreymal commented on 2020-09-08 16:54

Got it:

$ pkg-config --print-errors budgie-1.0
Package gobject-introspection-1.0 was not found in the pkg-config search path.
Perhaps you should add the directory containing `gobject-introspection-1.0.pc'
to the PKG_CONFIG_PATH environment variable
Package 'gobject-introspection-1.0', required by 'libpeas-1.0', not found

It seems there is a missing dependency. This fixed it for me:

sudo pacman -S gobject-introspection

Maybe this is missing libpeas dependency, dunno

andreymal commented on 2020-09-08 16:48

I have the same problem with budgie-1.0. The previous version was successfully built a few days ago

rilian commented on 2020-09-08 16:27

jextrevor, then it is strange, it should builds. Meson does not do anything fancy, it just looks into that file.

jextrevor commented on 2020-09-08 16:12

Yes, that file is present

rilian commented on 2020-09-08 15:58

You should have file /usr/lib/pkgconfig/budgie-1.0.pc in your system.