Package Details: vala-panel-appmenu-jayatana-git 0.7.0-2

Git Clone URL: https://aur.archlinux.org/vala-panel-appmenu-jayatana-git.git (read-only)
Package Base: vala-panel-appmenu-jayatana-git
Description: AppMenu module for Java Applications. Contains Bugs!
Upstream URL: https://gitlab.com/vala-panel-project/vala-panel-appmenu
Licenses: MIT
Provides: jayatana
Submitter: rilian
Maintainer: rilian
Last Packager: rilian
Votes: 1
Popularity: 0.001803
First Submitted: 2018-03-11 22:19
Last Updated: 2019-03-30 20:29

Dependencies (11)

Required by (4)

Sources (1)

Latest Comments

twilk commented on 2019-03-30 16:30

Hi @rilian! There seems to be a typo in the PKGBUILD, there's a comma after 'java-environment>=7' in depends (line 18). It seems like some AUR helpers ignore it (and the dependency is masked by the one in makedepends), but some choke on it instead. Would it be possible to remove the comma?

roachsinai commented on 2019-03-13 17:59

Hi @sergey.orloff do you mean it must be jdk8?

rilian commented on 2018-08-28 09:22

If only STDOUT message persists - it is a good result. Jayatana itself contian a lot of bugs, and these cosmetical (if really only cosmetical) warinigs are less evil than all checkboxes in JetBrains apps, or non-functional Java menus at all.

If you want, you can create issue on GitLab)

bogdanbiv commented on 2018-08-28 07:04

1) I believe we need to add java agent into the VM options, example: JAVA_TOOL_OPTIONS=-javaagent:/usr/share/java/jayatanaag.jar pycharm

2) ?are these the bugs we are warned off in the package description (command as above), excerpt from STDOUT: (java:4944): LIBDBUSMENU-GLIB-WARNING * : 09:38:52.120: About to Show called on an item wihtout submenus. We're ignoring it. (java:4944): LIBDBUSMENU-GLIB-WARNING * : 09:38:52.147: Menu item already has a parent (java:4944): LIBDBUSMENU-GLIB-CRITICAL * *: 09:38:52.150: dbusmenu_menuitem_child_append: assertion 'g_list_find(priv->children, child) == NULL' failed

As expected, Netbeans shows the same messages in STDOUT.

sergey.orloff commented on 2018-05-15 21:51

@Anonymo Hi! It was established so! 1) yaourt -S jdk8 2) sudo archlinux-java set java-8-jdk 3) archlinux-java status Available Java environments: java-8-jdk (java-8-jdk/jre default) java-8-jre/jre java-8-openjdk 4) makepkg -si

Anonymo commented on 2018-04-04 01:31

-- Build files have been written to: /tmp/yaourt-tmp-raul/aur-vala-panel-appmenu-jayatana-git/src/vala-panel-appmenu/subprojects/jayatana ==> Entering fakeroot environment... ==> Starting package()... make: *** No rule to make target 'install'. Stop. ==> ERROR: A failure occurred in package(). Aborting... ==> ERROR: Makepkg was unable to build vala-panel-appmenu-jayatana-git. ==> Restart building vala-panel-appmenu-jayatana-git ? [y/N] ==> -------------------------------------------------------- ==>