Package Details: vala-git 0.54.1+r150+gc46078fa4-1

Git Clone URL: https://aur.archlinux.org/vala-git.git (read-only, click to copy)
Package Base: vala-git
Description: Compiler for the GObject type system
Upstream URL: https://wiki.gnome.org/Projects/Vala
Keywords: compiler gobject programming
Licenses: LGPL
Conflicts: vala, valadoc
Provides: vala, valadoc
Submitter: None
Maintainer: swiftscythe
Last Packager: swiftscythe
Votes: 83
Popularity: 0.000000
First Submitted: 2009-10-23 08:57
Last Updated: 2022-01-03 16:44

Dependencies (14)

Required by (764)

Sources (1)

Latest Comments

1 2 3 4 5 Next › Last »

FabioLolix commented on 2022-01-03 16:57

Thanks for updating!

FabioLolix commented on 2022-01-03 16:23

About valadoc isn't much important but not needed anyway since official vala package have replace=(valadoc) since v0.38.1 on 13 Sep 2017, so who still have that package don't have updated in 4+ years,

provides/conflicts vala and valadoc is enough

About replaces vala, when the builded vala-git package is added to a repository, it will replace vala (or one of the legacy vala version if installed) when updating, the Arch wiki somewhere says to add replaces only when needed, i.e. when a package is dismissed for another.

I have some local custom repositories which host my clean build all my pkgbuilds and other AUR stuff I need or use

swiftscythe commented on 2022-01-03 16:07

@FabioLolix I keep it like this because the original package also replaces valadoc. Do you think it's enough with the provides array? What kind of effect does it have?

FabioLolix commented on 2022-01-03 15:51

Hello, replaces=(vala valadoc) is not needed and have a detrimeral effect when the builded package is added to repositories

omerkaraduman commented on 2021-09-28 08:20

This package is breaking package installation process called pamac-all-git, please fix that problem in addition to vala's other 0.54.1-1 version as well as is borking.

swiftscythe commented on 2020-12-23 08:45

@btd1337 version updated, thank you.

btd1337 commented on 2020-12-22 23:46

This package is using wrong version and is being displayed to other packages that require vala version lower than 0.44.

Please fix it. Consider to use latest version and to add vala-git in provide section.

FredBezies commented on 2019-01-24 10:13

Please add autoconf-archive to makedepends.

Without it, this error stops build process:

./configure: line 9220: syntax error near unexpected token `$flag,TEST_CFLAGS="$TEST_CFLAGS $flag"'

chenxiaolong commented on 2014-03-08 21:14

@misc: Thanks! It's fixed now.

misc commented on 2014-03-08 11:56

"vala[c] --version" should not result in "UNKNOWN", as it currently does. This causes many buildscripts to fail as they use this to check for a recent enough version.

A solution is to add "git describe --tag | sed 's/-.*//g' > .tarball-version" before the autogen line.