Package Details: uuid 1.6.2-18

Git Clone URL: https://aur.archlinux.org/uuid.git (read-only, click to copy)
Package Base: uuid
Description: OSSP Universally Unique Identifier
Upstream URL: http://www.ossp.org/pkg/lib/uuid
Licenses: MIT
Submitter: ilpianista
Maintainer: FryDay
Last Packager: FryDay
Votes: 77
Popularity: 0.007980
First Submitted: 2012-12-08 17:37
Last Updated: 2019-05-13 13:33

Pinned Comments

FryDay commented on 2019-04-12 14:26

Now sourced from a github mirror. Let me know if you have any issues.

Latest Comments

« First ‹ Previous 1 2 3 4 5 6 7 8 Next › Last »

CaptainHook8 commented on 2013-04-27 10:36

FTP is down for me too.
Thanks @brizou, i used the mirror you suggested.

brizou commented on 2013-04-26 07:50

Seems the ftp is down for me,
had to use this mirror
http://www.mirrorservice.org/sites/ftp.ossp.org/pkg/lib/uuid/

vwyodajl commented on 2013-04-23 18:02

Then you need to take it up with Manjaro dev's or boards. I can not debug for a system that is not Arch Linux.

This is working perfectly fine in Arch, so look at your distro for why its not, I am sure they have forums that will be of help.

Sorry.

Anonymous comment on 2013-04-23 17:59

And if i dot with supress the line after ./configure

he do this http://pastebin.com/Ly2GCzQj it looks like installed but when i compile pacmanager and start it, he say no uuid.pm locate ;).

Anonymous comment on 2013-04-23 17:56

@vwyodajl

Oups i've just seen i forgot to mention it, but i'm on Manjaro, not Arch... Sorry, don't know if it's changing something for you. Sorry i'm new on this system. I was on debian/centos before first time i decide to come on arch structure.

So i was doing, yaourt -S uuid to install it. ( in brackets the translation in english of the french part ;) )
==> Téléchargement du PKGBUILD de uuid depuis AUR... (Download of the PKGBUILD of uuid from AUR)
x ossp.patch
x PKGBUILD

==> Éditer PKGBUILD ? [O/n] ("A" pour annuler) (If i want to edit or not the file)
==> ------------------------------------------
==> n

==> Dépendances de uuid : (Dependencies already installed)
- sh (déjà installé)


==> Lancer la compilation de uuid ? [O/n] (start the compilation of uuid)

So sometimes the problem is that the tar.gz seems offline from the ftp, i have to change the source and take this one for example (http://www.mirrorservice.org/sites/ftp.ossp.org/pkg/lib/uuid/uuid-1.6.2.tar.gz)

=> Récupération des sources... (Downloading of the source)
-> Téléchargement de uuid-1.6.2.tar.gz…
% Total % Received % Xferd Average Speed Time Time Time Current
Dload Upload Total Spent Left Speed
100 387k 100 387k 0 0 354k 0 0:00:01 0:00:01 --:--:-- 355k
-> ossp.patch trouvé
==> Validation des fichiers sources avec md5sums…
uuid-1.6.2.tar.gz ... Réussite
ossp.patch ... Réussite (Ok find it and check md5 OK)
==> Extraction des sources...
-> Extraction de uuid-1.6.2.tar.gz avec bsdtar (Extract OK)
==> Lancement de build() (Now start the building)

all the process was here => http://pastebin.com/mFxxPfMx

Don't know if you have any idea ?

vwyodajl commented on 2013-04-23 17:05

I can not reproduce this. Can you give me more information about the issue you are hitting please.

Thanks

vwyodajl commented on 2013-04-23 16:39

@Mawelou
Will look into it today. But both packages built fine for me just now. Also did you try building uuid on its own?

vwyodajl commented on 2013-04-23 16:37

@Mawelou
Will look into it today. But both packages built fine for me just now.

vwyodajl commented on 2013-04-23 16:31

@Mawelou
Will look into it today. But both packages built fine for me just now.

Anonymous comment on 2013-04-23 16:03

@vwyodajl did you have any idea what's wrong.

During install of pacmanager, i arrived to the install of uuid (last package) and i have this error

Only one of PREFIX or INSTALL_BASE can be given. Not both.
make: *** [perl/blib/lib/OSSP/uuid.pm] Erreur 255

If i change the line 35 in PKGBUILD and delete the end to only let ./configure
35 ./configure
It doing the install, but when i launch pac i have an error
pac
Can't locate OSSP/uuid.pm in @INC (@INC contains: /usr/share/pacmanager/lib /usr/share/pacmanager/lib/ex /usr/share/pacmanager/lib/edit /home/mpi/perl5/lib/perl5/x86_64-linux-thread-multi /home/mpi/perl5/lib/perl5 /usr/lib/perl5/site_perl /usr/share/perl5/site_perl /usr/lib/perl5/vendor_perl /usr/share/perl5/vendor_perl /usr/lib/perl5/core_perl /usr/share/perl5/core_perl .) at /usr/share/pacmanager/lib/PACMain.pm line 39.
BEGIN failed--compilation aborted at /usr/share/pacmanager/lib/PACMain.pm line 39.
Compilation failed in require at /usr/bin/pac line 35.
BEGIN failed--compilation aborted at /usr/bin/pac line 35.

And of course no uuid.pm is find on the system. But if i try reinstall pacmanager, uuid appear like installed :).