Package Details: uuid 1.6.2-18

Git Clone URL: https://aur.archlinux.org/uuid.git (read-only)
Package Base: uuid
Description: OSSP Universally Unique Identifier
Upstream URL: http://www.ossp.org/pkg/lib/uuid
Licenses: MIT
Submitter: ilpianista
Maintainer: FryDay
Last Packager: FryDay
Votes: 77
Popularity: 0.008918
First Submitted: 2012-12-08 17:37
Last Updated: 2019-05-13 13:33

Pinned Comments

FryDay commented on 2019-04-12 14:26

Now sourced from a github mirror. Let me know if you have any issues.

Latest Comments

« First ‹ Previous 1 2 3 4 5 6 7 8 Next › Last »

adminempire commented on 2015-01-14 07:07

Again this is not out of date.

@Kubax
So building this as is in a clean chroot I do not see this issue when I stated I could not reproduce. I see nothing trying to set a patch to INSTALL_BASE=/home/$user/Perl5 .. http://pastebin.com/vWfn1tnT

@codekoala your patch fails hard. http://pastebin.com/AvTX2URM

What am I missing is the problem you two are having. Because I can not produce a pkg where this happens? This builds the same and fine for me in chroots on ALARM and Arch Linux i686, x86_64 boxes

codekoala commented on 2015-01-14 00:29

Thanks @Kubax! Your suggestion helped me get this package building again. I've posted an updated patch with your PREFIX => INSTALL_BASE change at https://gist.github.com/codekoala/a0c586ef88767a7feecd

adminempire commented on 2014-11-27 17:53

will look at it after the Holiday traveling currently.

Kubax commented on 2014-11-27 10:44

Fixed it.

in Makefile line 130 PREFIX musst be changed with INSTALL_BASE.

uuid.patch:
---------------SNIP--------------------
*** uuid-1.6.2/Makefile.old 2014-11-27 11:32:27.811528250 +0100
--- uuid-1.6.2/Makefile 2014-11-27 11:32:41.084733213 +0100
***************
*** 127,133 ****
@$(LIBTOOL) --mode=link $(CC) $(LDFLAGS) -o $(PRG_NAME) $(PRG_OBJS) $(LIB_NAME) $(LIBS)

$(PERL_NAME): $(PERL_OBJS) $(LIB_NAME)
! @cd $(S)/perl && $(PERL) Makefile.PL PREFIX=$(prefix) COMPAT=$(WITH_PERL_COMPAT) && $(MAKE) $(MFLAGS) all
@touch $(PERL_NAME)

$(PHP_NAME): $(PHP_OBJS) $(LIB_NAME)
--- 127,133 ----
@$(LIBTOOL) --mode=link $(CC) $(LDFLAGS) -o $(PRG_NAME) $(PRG_OBJS) $(LIB_NAME) $(LIBS)

$(PERL_NAME): $(PERL_OBJS) $(LIB_NAME)
! @cd $(S)/perl && $(PERL) Makefile.PL INSTALL_BASE=$(prefix) COMPAT=$(WITH_PERL_COMPAT) && $(MAKE) $(MFLAGS) all
@touch $(PERL_NAME)

$(PHP_NAME): $(PHP_OBJS) $(LIB_NAME)
---------------SNIP--------------------

cause of this problem is that with "perl Makefile.PL PREFIX=...." tries to set both. INSTALL_BASE=/home/$user/Perl5 AND PREFIX=/usr. Default value for PREFIX is "PREFIX = $(INSTALL_BASE)" so when PREFIX is set manually, both are different.

vwyodajl commented on 2013-09-24 16:40

I can not reproduce this.

Rebuilding the package is working fine
......snip
warning: uuid-1.6.2-11 is up to date -- reinstalling
resolving dependencies...
looking for inter-conflicts...

Packages (1):

Name Old Version New Version Net Change

uuid 1.6.2-11 1.6.2-11 0.00 MiB

Total Installed Size: 0.19 MiB
Net Upgrade Size: 0.00 MiB

:: Proceed with installation? [Y/n] y
(1/1) checking keys in keyring [----------------------] 100%
(1/1) checking package integrity [----------------------] 100%
(1/1) loading package files [----------------------] 100%
(1/1) checking for file conflicts [----------------------] 100%
(1/1) checking available disk space [----------------------] 100%
(1/1) reinstalling uuid [----------------------] 100%


Can you share more information so I can try and reproduce this.

bararchy commented on 2013-09-24 08:57

I got this issue when installing:

Checking if your kit is complete...
Looks good
Only one of PREFIX or INSTALL_BASE can be given. Not both.
make: *** [perl/blib/lib/OSSP/uuid.pm] Error 255
==> ERROR: A failure occurred in build().
Aborting...

Found a solution with this:
"unset PERL_MM_OPT"

brizou commented on 2013-09-24 08:56

same thing for me.

bararchy commented on 2013-09-24 08:43

I got this issue when installing:

Checking if your kit is complete...
Looks good
Only one of PREFIX or INSTALL_BASE can be given. Not both.
make: *** [perl/blib/lib/OSSP/uuid.pm] Error 255
==> ERROR: A failure occurred in build().
Aborting...

Found some info about it here:

http://git.661346.n2.nabble.com/PATCH-perl-Makefile-Unset-INSTALL-BASE-when-making-perl-mak-td5367737.html

bararchy commented on 2013-09-24 08:24

I got this issue when installing:

Checking if your kit is complete...
Looks good
Only one of PREFIX or INSTALL_BASE can be given. Not both.
make: *** [perl/blib/lib/OSSP/uuid.pm] Error 255
==> ERROR: A failure occurred in build().
Aborting...

vwyodajl commented on 2013-04-27 19:27

OK PKGBUILD updated with new mirror. No rev bump since that was the only change and no reason to make others rebuild this if its already installed.

Thanks for the heads up on the mirror change, this no longer gets updated so I forget to check once in awhile it still builds.