Package Details: urlview 0.9-13

Git Clone URL: https://aur.archlinux.org/urlview.git (read-only, click to copy)
Package Base: urlview
Description: A curses URL parser for text files
Upstream URL: http://packages.qa.debian.org/u/urlview.html
Licenses: GPL
Submitter: Snowman
Maintainer: Dragonlord
Last Packager: Dragonlord
Votes: 186
Popularity: 1.32
First Submitted: 2008-04-30 18:48
Last Updated: 2019-10-21 18:14

Latest Comments

« First ‹ Previous 1 2 3 4 Next › Last »

Lompik commented on 2014-12-14 18:26

Successfully built with bidulock's gist which also remove extra dependancy on autmake-1.11

gabx : it's just a warning

WhyNotHugo commented on 2014-11-26 16:39

These work:
http://ftp.de.debian.org/debian/pool/main/u/urlview/urlview_0.9-19.diff.gz
http://ftp.de.debian.org/debian/pool/main/u/urlview/urlview_0.9.orig.tar.gz
http://ftp.de.debian.org/debian/pool/main/u/urlview/urlview_0.9-19.dsc

WhyNotHugo commented on 2014-11-26 16:37

Mirror seems down.

gabx commented on 2014-10-09 21:42

build failed :
aclocal: warning: autoconf input should be named 'configure.ac', not 'configure.in'

bidulock commented on 2014-10-07 17:01

https://gist.github.com/bbidulock/30b8f8dc14b8d180a3a0

A PKGBUILD that does not require any special autotools.

tpreissler commented on 2014-04-13 19:17

I just tried to install this and it keeps complaining about automake-1.11. Ok so, ... here is my patch - it is a bit "dirty", but it works for me - on x86_64:

[ diff -Naur PKGBUILD-original PKGBUILD ]
--- PKGBUILD-original 2014-04-13 19:38:11.939636824 +0100
+++ PKGBUILD 2014-04-13 20:14:02.689981460 +0100
@@ -5,26 +5,23 @@
pkgrel=9
_patchlevel=19
pkgdesc="A curses URL parser for text files"
-arch=('i686' 'x86_64')
+arch=('x86_64')
url="http://packages.qa.debian.org/u/urlview.html"
license=('GPL')
depends=('bash' 'ncurses')
-makedepends=('patch' 'automake-1.11' 'autoconf')
-source=(http://ftp.debian.org/debian/pool/main/u/urlview/${pkgname}_$pkgver.orig.tar.gz \
- http://ftp.debian.org/debian/pool/main/u/urlview/${pkgname}_$pkgver-$_patchlevel.diff.gz)
-sha256sums=('746ff540ccf601645f500ee7743f443caf987d6380e61e5249fc15f7a455ed42'
- '056883c17756f849fb9235596d274fbc5bc0d944fcc072bdbb13d1e828301585')
-
-prepare() {
- cd ${srcdir}/$pkgname-$pkgver.orig
- patch -Np1 -i ${srcdir}/${pkgname}_${pkgver}-$_patchlevel.diff
- aclocal-1.11
-}
+makedepends=('patch' 'automake' 'autoconf')
+source=(http://ftp.debian.org/debian/pool/main/u/urlview/${pkgname}_$pkgver.orig.tar.gz)
+sha256sums=('746ff540ccf601645f500ee7743f443caf987d6380e61e5249fc15f7a455ed42')

build() {
cd ${srcdir}/$pkgname-$pkgver.orig

- ./configure --prefix=/usr
+ unset CXXFLAGS
+ unset CPPFLAGS
+ unset CFLAGS
+ unset CHOST
+
+ ./configure
make
}

Dragonlord commented on 2014-04-02 19:07

https://aur.archlinux.org/packages/automake-1.11/ is needed

eldruz commented on 2014-04-02 06:41

The automake version does not match the one in the repositories.

rtfreedman commented on 2013-12-11 19:46

Please add 'automake-1.11' to makedepends.
I also had to put aclocal-1.11 just after 'patch -Np1 -i ...'
- at least when using _patchlevel=19

misc commented on 2013-06-18 19:03

debian has patchlevel 19.