Package Details: urlview 0.9-13

Git Clone URL: https://aur.archlinux.org/urlview.git (read-only, click to copy)
Package Base: urlview
Description: A curses URL parser for text files
Upstream URL: http://packages.qa.debian.org/u/urlview.html
Licenses: GPL
Submitter: Snowman
Maintainer: Dragonlord
Last Packager: Dragonlord
Votes: 188
Popularity: 1.42
First Submitted: 2008-04-30 18:48
Last Updated: 2019-10-21 18:14

Latest Comments

1 2 3 4 Next › Last »

grawlinson commented on 2020-03-19 20:21

bergentroll: The canonical source of urlview isn't actually debian. Seems to be here.

bergentroll commented on 2019-10-22 07:47

Dragonlord, current versioning is a bit confusing. v0.9-13 corresponds to v0.9-21 of Debian upstream. So why not just to use pkgrel for patchlevel and epoch for package downstream versioning? Or, if you dislike epoch, you may set e.g. _upsver=0.9 and pkgver=${_upsver}.${_patchlevel}.

grawlinson commented on 2019-09-25 00:38

Hi Dragonlord, are you able to implement bergentroll's one-liner fix? I can confirm that it works flawlessly.

bergentroll commented on 2019-06-17 16:55

It seems something changed. Patch gzipped file have not being unpacked to $SRC, so build crashes on prepare(). It seems it is because bsdtar does not handle *.gz files. I really does no know why things worked and than became broken. The next line in beginning of prepare() fixes the issue:

gunzip --force "${srcdir}/${pkgname}_${pkgver}-$_patchlevel.diff.gz"

dude commented on 2018-12-20 09:18

@srand I'm a bit late here but I created a urlview-git package that includes this patch, if anyone is interested.

https://aur.archlinux.org/packages/urlview-git/

srand commented on 2017-05-07 21:51

Would be nice if the package included this patch, it applies flawlessly and is already merged upstream (https://github.com/sigpipe/urlview), but it doesn't seem like there will be a new release anytime soon.

https://patch-diff.githubusercontent.com/raw/sigpipe/urlview/pull/5.patch

angyath commented on 2016-09-28 22:57

PKGBUILD is missing makedepends=('automake' 'autoconf')

vonpupp commented on 2016-09-20 04:07

Hello, could you please include 'aarch64' architecture? Thank you!

Jonhoo commented on 2015-09-18 15:20

A pkgrel bump to force recompile with ncurses 6 would be appreciated.

duckunix commented on 2015-02-19 12:00

Can you add 'armv7h' to the supported architectures? It works just great on the ARM!

Thanks for the package!