Package Details: unluac 2016_11_20-1

Git Clone URL: https://aur.archlinux.org/unluac.git (read-only)
Package Base: unluac
Description: a decompiler for Lua 5.1
Upstream URL: http://sourceforge.net/projects/unluac/
Licenses: MIT
Submitter: jose1711
Maintainer: jose1711
Last Packager: jose1711
Votes: 0
Popularity: 0.000000
First Submitted: 2015-04-13 08:03
Last Updated: 2016-11-20 20:54

Latest Comments

jose1711 commented on 2016-11-20 20:54

@xarkes: thank you, updated

xarkes commented on 2016-11-20 16:58

The build is failing since the latest version is different than the one in the package.
I don't know if there is any pull request system here so I'm just going to share my PKGBUILD file:
# Maintainer: jose <jose1711 [at] gmail (dot) com>

pkgname=unluac
pkgver=2016_11_20
pkgrel=2
pkgdesc="a decompiler for Lua 5.1"
arch=('any')
url="http://sourceforge.net/projects/unluac/"
depends=('java-runtime')
license=('MIT')
source=("http://sourceforge.net/projects/unluac/files/latest" unluac.sh)

package() {
cd $srcdir
install -Dm644 ${srcdir}/latest $pkgdir/usr/share/java/${pkgname}/${pkgname}.jar
install -Dm755 ${srcdir}/unluac.sh $pkgdir/usr/bin/unluac
}
md5sums=('3fcbd73cc6ca07189f105fcaf1898267'
'f86eb01199590ec711691c2c0f5ac539')