Package Details: unknown-horizons 2019.1-2

Git Clone URL: https://aur.archlinux.org/unknown-horizons.git (read-only)
Package Base: unknown-horizons
Description: 2D realtime strategy simulation with an emphasis on economy and city building.
Upstream URL: http://www.unknown-horizons.org/
Keywords: Anno Game OpenSource Realtime Strategy
Licenses: GPL, CCPL
Conflicts: unknown-horizons-git
Submitter: biginoz
Maintainer: Lucki
Last Packager: Lucki
Votes: 81
Popularity: 0.277563
First Submitted: 2010-08-17 18:05
Last Updated: 2019-06-14 14:36

Latest Comments

« First ‹ Previous 1 2 3 4 5 6 7 Next › Last »

ChrisOelmueller commented on 2014-08-19 13:10

(Sorry again about this prolonged period of silence.)

Were any of you using `fife-svn` or `fife-git` packages to provide fife? (If you're still using the now-deleted `fife-svn`, make sure to upgrade to `fife` sometime.) For now I've added

[pkgrel 6] - an ugly hack to require non-git fife

but still can't reproduce these issues on my system. If nothing else helps, perhaps try `unknown-horizons-git` and `fife` packages.

pulsar68 commented on 2014-05-29 06:57

Same here

skiwi commented on 2014-05-17 14:04

I get the same error as tacloban.

tacloban commented on 2014-04-24 05:49

maybe I have a font issue?

tacloban commented on 2014-04-24 05:46

Tried the latest from AUR, 2013.3-5, getting a different error now:


libpng warning: iCCP: Not recognizing known sRGB profile that has been edited
Traceback (most recent call last):
File "/usr/bin/unknown-horizons", line 473, in <module>
main()
File "/usr/bin/unknown-horizons", line 283, in main
ret = horizons.main.start(options)
File "/usr/lib/python2.7/site-packages/horizons/main.py", line 179, in start
horizons.globals.fife.init()
File "/usr/lib/python2.7/site-packages/horizons/engine/engine.py", line 159, in init
self._setting.apply()
File "/usr/lib/python2.7/site-packages/horizons/engine/settings.py", line 87, in apply
change_language(language)
File "/usr/lib/python2.7/site-packages/horizons/i18n/__init__.py", line 125, in change_language
horizons.globals.fife.pychan.loadFonts(fontdef)
File "/usr/lib/python2.7/site-packages/fife/extensions/pychan/fonts.py", line 88, in loadFonts
for font in Font.loadFromFile(filename):
File "/usr/lib/python2.7/site-packages/fife/extensions/pychan/fonts.py", line 73, in loadFromFile
fonts.append( Font(name,_get) )
File "/usr/lib/python2.7/site-packages/fife/extensions/pychan/fonts.py", line 46, in __init__
self.font.setAntiAlias(self.antialias)
File "/usr/lib/python2.7/site-packages/fife/fife.py", line 3233, in setAntiAlias
return _fife.GuiFont_setAntiAlias(self, *args)
TypeError: in method 'GuiFont_setAntiAlias', argument 2 of type 'bool'
AL lib: (EE) alc_cleanup: 1 device not closed

ChrisOelmueller commented on 2014-04-21 23:05

After some debugging and testing in #unknown-horizons:

[pkgrel 5] - patch a couple of lines that might break with fife 0.3.5

Hopefully that fixes the issue reported some weeks ago (sorry about the delay).

tacloban commented on 2014-04-06 15:33

I get this when trying to run this version, 2013.3-4:


Traceback (most recent call last):
File "/usr/bin/unknown-horizons", line 473, in <module>
main()
File "/usr/bin/unknown-horizons", line 283, in main
ret = horizons.main.start(options)
File "/usr/lib/python2.7/site-packages/horizons/main.py", line 102, in start
horizons.globals.fife = Fife()
File "/usr/lib/python2.7/site-packages/horizons/engine/engine.py", line 50, in __init__
self.init_logging()
File "/usr/lib/python2.7/site-packages/horizons/engine/engine.py", line 124, in init_logging
self._setting.get(SETTINGS.FIFE_MODULE, "LogToFile", "0"))
File "/usr/lib/python2.7/site-packages/fife/extensions/fifelog.py", line 42, in __init__
self.lm.setLogToPrompt(promptlog)
File "/usr/lib/python2.7/site-packages/fife/fife.py", line 12721, in setLogToPrompt
return _fife.LogManager_setLogToPrompt(self, *args)
TypeError: in method 'LogManager_setLogToPrompt', argument 2 of type 'bool'

ChrisOelmueller commented on 2014-01-03 20:33

Which version of Fife is installed? Any debug output from UH?

NebuPookins commented on 2013-12-31 18:25

When I try to run this game, I get a dialog box that says "Failed to find and/or load FIFE."

ChrisOelmueller commented on 2013-10-09 15:34

Good catch, thanks!

[pkgrel 4] - update source, add intltool dependency