Package Details: unity-editor 1:2019.1.14f1-1

Git Clone URL: https://aur.archlinux.org/unity-editor.git (read-only)
Package Base: unity-editor
Description: The world's most popular development platform for creating 2D and 3D multiplatform games and interactive experiences.
Upstream URL: https://unity3d.com/
Keywords: develop engine gamedev unity3d
Licenses: custom
Submitter: LeonardK
Maintainer: spacepluk (jurf, fwalch)
Last Packager: spacepluk
Votes: 147
Popularity: 1.204171
First Submitted: 2015-08-26 18:08
Last Updated: 2019-08-10 07:28

Sources (5)

Pinned Comments

spacepluk commented on 2018-01-19 12:03

MonoDevelop is officially deprecated: https://blogs.unity3d.com/2018/01/05/discontinuing-support-for-monodevelop-unity-starting-in-unity-2018-1/

spacepluk commented on 2018-01-03 10:01

Following 2013.3.0f1 all the components in UnitySetup correspond to separate AUR packages.

So, for example to get the editor with Android build support you need to install both: unity-editor-beta and unity-editor-beta-android. Check the optional dependencies for the other platforms/components.

MonoDevelop is not included since 2013.3.0b1: https://forum.unity.com/threads/2017-3-0b1-editor-issues.498477/#post-3242701

jurf commented on 2016-11-07 21:01

This is not the beta package! Please do not flag it out of date if the new version has the letter "b" in it. Instead please look at https://aur.archlinux.org/packages/unity-editor-beta/

Latest Comments

1 2 3 4 5 6 ... Next › Last »

xploreitcorp commented on 2019-08-19 05:24

very helpful and informative blog. Thank you for

your information.If you are searching for Angular

training in kochi visit us https://www.xploreitcorp.com/angular-training-kochi/">Angular training in

kochi,Angular courses in kochi ||

Toric commented on 2019-07-30 03:26

is there any way to target mono 3.5? installing the AUR package https://aur.archlinux.org/packages/referenceassemblies-3.5-bin/, but it still says that target framework 3.5 is not installed...

ijann commented on 2019-04-24 22:57

Hello people, a consultation, to you, you are conjela the window, I have noticed that certain windows stop, in my case it happens to me with the Animation window, in some occasions I am using and when I go to that window I can not create a transition, I can not right click, On other occasions, it happened to me, when I wanted to create a script from the Inspector window, he would not let me write the name, someone happens to that, I tell you that I use Manjaro Cinnamon

algebro commented on 2019-04-19 13:14

Thanks @spacepluk, I opened a thread on the Unity forums the other day and haven't heard back yet. I have an AMD RX580 with mesa/vulkan-radeon 19.0.2 and LLVM 8.0.0. It shouldn't be a problem with the OpenGL version because glxinfo shows OpenGL 4.5.

I also tried installing 2019.1 via unityhub and ran into the same problem, so I don't think it's an issue with this package. Given that, I'll plan to continue to troubleshoot on the Unity forums, although I'd be curious to know if this happens to anyone else on Arch (in case it's a problem with dependency versions packaged by Arch).

spacepluk commented on 2019-04-19 08:14

@algebro In any case I would take this to the forum https://forum.unity.com/forums/linux-editor.93/

spacepluk commented on 2019-04-19 08:11

hey @algebro what GPU are you trying to use with unity? the editor requires at least OpenGL 3.2 if I remember correctly.

algebro commented on 2019-04-16 20:31

I am unable to open or create projects after the 2019 update--It just crashes after going through the project prompts. Is this happening to anyone else?

Here's the error I'm getting when I try to open a project:

libGL: pci id for fd 54: 1002:67df, driver radeonsi
libGL: MESA-LOADER: failed to open /usr/lib/dri/radeonsi_dri.so: /usr/lib/dri/radeonsi_dri.so: undefined symbol: amdgpu_bo_list_create_raw
libGL error: MESA-LOADER: failed to open radeonsi (search paths /usr/lib/dri)
libGL error: failed to load driver: radeonsi
libGL: Can't open configuration file /etc/drirc: No such file or directory.
libGL: Can't open configuration file /home/algebro/.drirc: No such file or directory.
libGL: pci id for fd 54: 1002:67df, driver radeonsi
libGL: MESA-LOADER: failed to open /usr/lib/dri/radeonsi_dri.so: /usr/lib/dri/radeonsi_dri.so: undefined symbol: amdgpu_bo_list_create_raw
libGL error: MESA-LOADER: failed to open radeonsi (search paths /usr/lib/dri)
libGL error: failed to load driver: radeonsi
libGL: MESA-LOADER: failed to open /usr/lib/dri/swrast_dri.so: /usr/lib/dri/swrast_dri.so: undefined symbol: amdgpu_bo_list_create_raw
libGL error: MESA-LOADER: failed to open swrast (search paths /usr/lib/dri)
libGL error: failed to load driver: swrast
Segmentation fault (core dumped)

Also oddly enough I'm getting a prompt saying the project I just created was created with an older version of unity and that it needs to be upgraded.

Downgrading to 2018.3.12f1-1 fixes the crashes, although now I'm getting dependency errors/missing assemblies when I try to open my existing projects.

Update: here is the crash in Editor.log:

[vulkan] LoadVulkanLibrary libvulkan.so.1[vulkan] Loaded function vkGetInstanceProcAddr
[vulkan] Loaded function vkGetInstanceProcAddr
[vulkan] Loaded function vkCreateInstance
[vulkan] Loaded function vkDestroyInstance
[vulkan] Loaded function vkEnumerateInstanceExtensionProperties
[vulkan] Loaded function vkEnumerateInstanceLayerProperties
[vulkan] Loaded function vkEnumeratePhysicalDevices
[vulkan] Loaded function vkGetPhysicalDeviceProperties
[Vulkan init] extensions: count=2
[Vulkan init] extensions: name=VK_EXT_debug_report, enabled=1
[Vulkan init] extensions: name=VK_EXT_debug_utils, enabled=0
Vulkan error VK_ERROR_INCOMPATIBLE_DRIVER (-9) file: ./Runtime/GfxDevice/vulkan/VKContext.cpp, line: 333
Vulkan error./Runtime/GfxDevice/vulkan/VKContext.cpp:333

nerdnils commented on 2019-04-01 18:01

Crashes when creating a project. Reproducable. Memory Access error. Expected more from this

spacepluk commented on 2019-03-17 16:40

@weedfreak no problem, glad you figured it out.

weedfreak commented on 2019-03-15 13:13

Trying to update to 2018.3.8f1 I get an error messgage that cannot extract xz file, no room left on device. The install folder has 64 Gb free but the file registers itself as containing 3.4 Tb of data, the download is only ~800Mb and I tried it twice with the same results.

Ignore this, problem was with system update done earlier today, nothing to do with this package, all solved now. Sorry for the noise.