Package Details: unity-editor-beta 2019.2.0b2-1

Git Clone URL: https://aur.archlinux.org/unity-editor-beta.git (read-only)
Package Base: unity-editor-beta
Description: The world's most popular development platform for creating 2D and 3D multiplatform games and interactive experiences.
Upstream URL: https://unity3d.com/
Keywords: beta develop engine gamedev unity3d
Licenses: custom
Submitter: spacepluk
Maintainer: spacepluk
Last Packager: spacepluk
Votes: 25
Popularity: 0.748336
First Submitted: 2016-03-16 16:54
Last Updated: 2019-05-17 11:23

Sources (5)

Pinned Comments

spacepluk commented on 2017-10-05 15:38

Following 2013.3.0b1 all the components in UnitySetup correspond to separate AUR packages.

So, for example to get the editor with Android build support you need to install both: unity-editor-beta and unity-editor-beta-android. Check the optional dependencies for the other platforms/components.

MonoDevelop wasn't included in this build: https://forum.unity.com/threads/2017-3-0b1-editor-issues.498477/#post-3242701

Latest Comments

« First ‹ Previous 1 2 3 4 Next › Last »

Lattyware commented on 2017-07-10 13:16

Having fun again with 2017.2.0b2 - when I launch and try to open a project, I get:

Failed to resolve packages. Please see Editor.log file for more information

Editor.log contains:

Desktop is 7680 x 3600 @ 60 Hz

LICENSE SYSTEM [2017710 14:9:11] No start/stop license dates set

LICENSE SYSTEM [2017710 14:9:11] Next license update check is after 2017-07-07T14:22:03


COMMAND LINE ARGUMENTS:
/opt/UnityBeta/Editor/Unity
[0710/140911:ERROR:browser_main_loop.cc(161)] Running without the SUID sandbox! See https://code.google.com/p/chromium/wiki/LinuxSUIDSandboxDevelopment for more information on developing with the sandbox on.
[0710/140911:ERROR:renderer_main.cc(227)] Running without renderer sandbox
[0710/140911:ERROR:gpu_process_transport_factory.cc(402)] Failed to establish GPU channel.
IsTimeToCheckForNewEditor: Update time 0 current 1499692152
/home/gareth/Work/test
UpdateMenuTitleForLanguage: 10
Loading GUID <-> Path mappings...0.000038 seconds
Loading Asset Database...0.005138 seconds
Audio: FMOD Profiler initialized on port 54901
AudioManager: Using PulseAudio: Default Output Device
AssetDatabase consistency checks...0.256904 seconds
Refreshing native plugins compatible for Editor in 12.88 ms, found 0 plugins.
Preloading 0 native plugins for Editor in 0.00 ms.
PackageManager Server::Start -- Port 58220 was selected
events.js:160
throw er; // Unhandled 'error' event
^

Error: write EPIPE
at exports._errnoException (util.js:1022:11)
at WriteWrap.afterWrite (net.js:801:14)

As always, hard to say if this is a packaging issue or actual Unity-side issue.

ArXen42 commented on 2017-06-22 00:11

Download link is broken (it seems like there was no new beta version but the link had slightly changed). Corrent link is now http://beta.unity3d.com/download/45784aaa9968/unity-editor-installer-2017.1.0xb8Linux.sh.

Lattyware commented on 2017-06-18 17:09

@spacepluk I meant to reply earlier, but forgot - it's working for me now, thanks for the fix.

spacepluk commented on 2017-06-15 09:19

@Lattyware, I think it's fixed now :)

spacepluk commented on 2017-06-14 16:24

Hmm, I saw that and I just assumed it was an upstream thing. I'll check it out tomorrow. Thanks for the heads up.

Lattyware commented on 2017-06-14 15:47

I am having problems ever since the change to the 2017.1.0 version. "Failed to load package manager" repeatedly in the editor logs. Not sure if it's an issue with the editor itself or the packaging.

I've posted about it on the Unity forums: https://forum.unity3d.com/threads/2017-1-0b8-failed-to-load-package-manager.470997/

The response was that it sounds to them like 'a bad installation', and apparently other Arch users have the same problem - so I'm wondering if this is a packaging issue.

ParkerMc commented on 2017-03-13 17:21

@spacepluk Still get the crash. I have a full log here if it helps. https://gist.github.com/ParkerMc/f9257d1c0a608171e103ff2bb98b9c80
Edit: this happens on all projects even new ones when ever I open a project.

spacepluk commented on 2017-03-13 10:51

hi @ParkerMc, maybe try launching unity with -no-throttle-updates?

ParkerMc commented on 2017-03-13 03:21

I am getting this crash with the newest one the unity-editor one works. Any ideas on what I can do or is this something unity needs to fix?
[xcb] Unknown sequence number while processing queue
[xcb] Most likely this is a multi-threaded client and XInitThreads has not been called
[xcb] Aborting, sorry about that.
Unity: xcb_io.c:259: poll_for_event: Assertion `!xcb_xlib_threads_sequence_lost' failed.

GreenByte commented on 2017-03-06 17:46

A new beta is out. The first sha256 sum is: eae3fb763c85701bc5d8d2b13ca14aee697de98e6f58cb79e435801b4d7553dc and the source file is: http://beta.unity3d.com/download/b9488c3b1f9f/unity-editor-installer-5.6.0xb10Linux.sh

_build=b10
_buildtag=20170306