Package Details: unigine-heaven 4.0-2

Git Clone URL: https://aur.archlinux.org/unigine-heaven.git (read-only, click to copy)
Package Base: unigine-heaven
Description: Unigine Benchmark
Upstream URL: http://www.unigine.com
Licenses: custom:UNIGINE Engine
Submitter: None
Maintainer: xythrez
Last Packager: xythrez
Votes: 149
Popularity: 1.15
First Submitted: 2010-03-24 15:44
Last Updated: 2019-06-21 03:37

Latest Comments

1 2 3 4 5 6 Next › Last »

LizziAS commented on 2020-12-24 01:47

@xythrez sorry i missed that. will do. i had 3 out of 5 fail to d/l so i got hasty i guess.

xythrez commented on 2020-12-24 01:12

@LizziAS theres something wrong with your partial download. Try building again in an empty directory

LizziAS commented on 2020-12-24 00:54

makepkg -si ==> Making package: unigine-heaven 4.0-2 (Wed 23 Dec 2020 07:53:55 PM EST) ==> Checking runtime dependencies... ==> Checking buildtime dependencies... ==> Retrieving sources... -> Downloading Unigine_Heaven-4.0.run... ** Resuming transfer from byte position 308645770 % Total % Received % Xferd Average Speed Time Time Time Current Dload Upload Total Spent Left Speed 100 170 100 170 0 0 580 0 --:--:-- --:--:-- --:--:-- 580 0 206 0 0 0 0 0 0 --:--:-- --:--:-- --:--:-- 0 curl: (22) The requested URL returned error: 416 ==> ERROR: Failure while downloading https://assets.unigine.com/d/Unigine_Heaven-4.0.run Aborting...

xythrez commented on 2019-11-21 23:43

@Semaphor You seem to be missing some UTF fonts. Can you try installing the 'xorg-fonts-misc' package and build again?

Semaphor commented on 2019-11-21 19:11

Package fails to install because fonts:

==> Starting build()...

xterm: cannot load font "-misc-fixed-medium-r-semicondensed--13-120-75-75-c-60-iso10646-1"

==> Entering fakeroot environment...

==> Starting package()...

/var/tmp/pamac-build-mark/unigine-heaven/PKGBUILD: line 27: cd: /var/tmp/pamac-build-mark/unigine-heaven/src/Unigine_Heaven-4.0: No such file or directory

==> ERROR: A failure occurred in package().

jamincollins commented on 2017-04-13 22:59

current package fails to build, the following diff corrects it:

diff --git a/PKGBUILD b/PKGBUILD
index ae5c6f9..84ae3d3 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -20,10 +20,10 @@ sha512sums=('f075968d9812c7bd6a19cd27c48612203ce81f48b14ba56239419957fd3342adb31
[ "${CARCH}" = "x86_64" ] && _arch=x64

build() {
- sh "${_pkgname}"-"${pkgver}".run --target "${pkgname}" --noexec
+ sh "${_pkgname}"-"${pkgver}".run -- --target "${pkgname}" --noexec
}
package() {
- cd "${srcdir}"/"${pkgname}"
+ cd "${srcdir}"/"${_pkgname}-${pkgver}"
install -d "${pkgdir}"/opt/"${pkgname}"/bin/
install -m775 bin/*_"${_arch}"* "${pkgdir}"/opt/"${pkgname}"/bin/
cp -R data "${pkgdir}"/opt/"${pkgname}"/

rexct commented on 2017-02-01 09:03

Unigine_Heaven-4.0.run seems has different sha512 checksum.
New checksum is
f075968d9812c7bd6a19cd27c48612203ce81f48b14ba56239419957fd3342adb31267ed8c261b7b1c68e2589a07d4cee84b199fb12d8d69e2d6a34fbdcf76c1

dariost commented on 2017-01-22 01:07

The download link ( http://uk1-dl.techpowerup.com/Benchmarking/Unigine_Heaven-4.0.run ) gives error 404

Behem0th commented on 2014-10-17 19:03

@seandarcy

It problem in open source radeon driver. first try update llvm.

seandarcy commented on 2014-10-17 18:50

./heaven
Loading "/opt/10/benchmark/Unigine_Heaven-4.0/bin/../data/heaven_4.0.cfg"...
Loading "libGPUMonitor_x64.so"...
Loading "libGL.so.1"...
Loading "libopenal.so.1"...
Set 1366x768 windowed video mode
Set 1.00 gamma value
Unigine engine http://unigine.com/
Binary: Linux 64bit GCC 4.4.5 Release Feb 13 2013 r11274
Features: OpenGL OpenAL XPad360 Joystick Flash Editor
........
CPU: AMD A8-7100 Radeon R5, 8 Compute Cores 4C+4G 1796MHz MMX+ SSE SSE2 SSE3 SSSE3 SSE41 SSE42 SSE4A SSE5 AVX HTT x4
GPU: Unknown GPU x1
System memory: 4908 MB
Video memory: 256 MB
Sync threads: 3
Async threads: 4
...............
---- Render ----
GLRender::GLRender(): Unknown GPU
OpenGL vendor: X.Org
OpenGL renderer: Gallium 0.4 on AMD KAVERI
OpenGL version: 3.2 (Core Profile) Mesa 10.3.0
OpenGL flags: Core Profile
Found required GL_ARB_map_buffer_range
Found required GL_ARB_vertex_array_object
Found required GL_ARB_draw_instanced
Found required GL_ARB_draw_elements_base_vertex
Found required GL_ARB_transform_feedback
Found required GL_ARB_half_float_vertex
Found required GL_ARB_half_float_pixel
Found required GL_ARB_framebuffer_object
Found required GL_ARB_texture_multisample
Found required GL_ARB_uniform_buffer_object
Found required GL_ARB_geometry_shader4
Found optional GL_ARB_sample_shading
Found optional GL_ARB_texture_compression_rgtc
Shading language: 3.30
Maximum texture size: 16384
Maximum texture units: 48
Maximum texture renders: 8
..............
Loading "heaven/heaven.world" 20287ms
LLVM ERROR: Cannot select: 0x89a28b0: i32 = truncate 0x898d0d0 [ORD=19] [ID=149]
0x898d0d0: i128 = srl 0x899cd00, 0x89a22a0 [ORD=19] [ID=129]
0x899cd00: i128,ch = load 0x89522e8, 0x8986650, 0x8987a60<LD16[%30](tbaa=!"const")> [ORD=19] [ID=119]
0x8986650: i64,ch = CopyFromReg 0x89522e8, 0x8986550 [ID=110]
0x8986550: i64 = Register %vreg100 [ID=2]
0x8987a60: i64 = undef [ID=8]
0x89a22a0: i32 = Constant<96> [ID=105]
In function: main

Is this an upstream Unigine problem? If so, any clue how to report it?

I'm still at llvm-3.4-2. Is that the problem?