Package Details: unifi-video 3.10.13-1

Git Clone URL: https://aur.archlinux.org/unifi-video.git (read-only, click to copy)
Package Base: unifi-video
Description: Centralized management system for Ubiquiti UniFi surveillance cameras.
Upstream URL: https://www.ubnt.com/
Licenses: custom
Conflicts: unifi-video-beta
Submitter: fryfrog
Maintainer: fryfrog
Last Packager: fryfrog
Votes: 11
Popularity: 0.001836
First Submitted: 2016-04-18 17:44
Last Updated: 2020-10-11 02:45

Latest Comments

« First ‹ Previous 1 2 3 4 Next › Last »

paco3346 commented on 2017-05-04 02:40

Bingo! 4 hours later...

There's something broken with the gzip compression in tomcat.
You can disable it by modifying /usr/lib/unifi-video/conf/server.xml and looking for all references of compression="on"

I'll let you guess what value you should update it to :)

Also, this is no longer jre7 compatible. Lots of "Could not initialize class javax.imageio.ImageIO" Runs swimmingly well with 8

Hey, me again. Edit #3. You'll also need to sudo chown -R unufi-video:unifi-video /usr/lib/unifi-video/conf/evostream/ if you run into problems with getting a single frame of video but no stream or recording

fryfrog commented on 2017-03-26 03:45

I had enough trouble w/ unifi-video on Arch that I've switched to using a docker image based on Ubuntu. I found an existing one that was pretty good and then improved the heck out of it.

If any of you are having trouble w/ it from this AUR package, consider giving the docker version a try.

https://hub.docker.com/r/pducharme/unifi-video-controller/

fryfrog commented on 2017-02-21 20:24

An Ubuntu vm was my next step if I hadn't just randomly tried to load up video.ubnt.com for no dang reason and it saw my nvr. I didn't even know it'd do that.

ssgross commented on 2017-02-21 19:03

Will try doing fryfrog's suggestion when i get a chance. For now, I have it up in running in a headless vm running ubuntu. i also had success with it working using a docker container following the suggestions of
https://github.com/rednut/docker-unifi-video-controller

fryfrog commented on 2017-02-19 03:58

Can those that have been having problems try doing the setup using https://video.ubnt.com from a computer on the network where the nvr software is installed? I just tried that after spending a few frustrating hours trying to do it as I'd expected using http://ip:7080/. It worked. :/

fryfrog commented on 2017-02-19 02:48

I did a clean install and I'm having the same issue now. I can do step 1 and 2, but can't log in afterward. It just spits me back out to a login prompt. I tried downgrading to 3.6.0 and 3.5.2, but it did the same thing. There isn't even anything useful in the logs, I can see me log in but nothing else.

SH1986 commented on 2017-01-29 19:07

Hi fryfrog,

The strange thing is, that there are no real errors in the log files. The only error line I got is:

ERROR UpdateService: Error - airvisionUpdateInfo is null in UpdateService-UpdateCheckTask
ERROR UpdateService - processAirVisionUpdate() - No Airvision Update Info in UpdateService-UpdateCheckTask

I have now tried this on a totally clean/reinstall archlinux, there is nothing else installed than unification-video.

Best Regards
Soren Hansen

fryfrog commented on 2017-01-29 03:19

Is there anything in the logs?

SH1986 commented on 2017-01-29 00:18

ssgross, did you managed to get this version running on arch? I have exact the same problem as you "Unexpected Error, the server responded with status code of 404" I have tried with a clean install of this packaged (Deleted all my config) but the problem persists.

ssgross commented on 2017-01-25 19:23

found an error that appears sometimes, and sometimes not, about wired tiger not being able to connect to mongodb.
Also curios: I installed a clean vm install of the latest ubuntu 16.04lts. I was unable to install unifi-video there because it claims openjdk 8 headless as a dependency, but only 7 is available in any of the repos, even after a full update/upgrade. i'm going to try and make a pkg build for an older version of unifi-video and see if i can get it to work...consistantly. i think there is some versioning or library version issues that are preventing it from running in arch. i'm hesitant to start up a thread at ubnt, all of the other distro related questions there get either unanswered, or end simply with no support is planned.