Package Details: uni 1.1.1-1

Git Clone URL: https://aur.archlinux.org/uni.git (read-only, click to copy)
Package Base: uni
Description: Query the Unicode database from the commandline, with good support for emojis
Upstream URL: https://github.com/arp242/uni
Licenses: MIT
Submitter: Gondolin
Maintainer: Gondolin
Last Packager: Gondolin
Votes: 1
Popularity: 0.002912
First Submitted: 2020-02-08 21:41
Last Updated: 2020-06-01 12:22

Dependencies (1)

Required by (0)

Sources (1)

Latest Comments

muesli commented on 2020-10-19 06:50

@makeworld I've just fixed this error in uni. We'll just need a new release now, though.

makeworld commented on 2020-09-21 23:19

Building/installing failed:

==> Starting check()...
# arp242.net/uni/unidata
unidata/data.go:36:9: conversion from uint32 to string yields a string of one rune, not a string of digits (did you mean fmt.Sprint(x)?)
unidata/data.go:42:8: conversion from uint32 to string yields a string of one rune, not a string of digits (did you mean fmt.Sprint(x)?)
ok      arp242.net/uni  0.265s
ok      arp242.net/uni/isatty   0.004s
?       arp242.net/uni/terminal [no test files]
==> ERROR: A failure occurred in check().
    Aborting...
error making: uni

Gondolin commented on 2020-05-31 13:58

@dreieck: I am following the go guidelines at https://wiki.archlinux.org/index.php/Go_package_guidelines

The original discussion at https://lists.archlinux.org/pipermail/arch-dev-public/2020-May/029964.html included doing a go mod vendor in the prepare step, but this has been dropped in the published guidelines.

However I am not against adding it back if you care strongly about this.

dreieck commented on 2020-05-06 11:54

This package downloads stuff in build() and check().

This must not happen. No internetconnection must be assumed in build(), check() and package().

Please use depends, source and as an exception the prepare()-function.

==> Starting build()...
go: downloading golang.org/x/sys v0.0.0-20191120155948-bd437916bb0e
==> Starting check()...
go: downloading zgo.at/ztest v1.0.0
go: downloading github.com/google/go-cmp v0.3.1

Thanks for maintaining!

Gondolin commented on 2020-04-09 21:38

I know that v1.1 is out, but I am waiting for https://github.com/arp242/uni/issues/14 to be fixed.